Support » Plugin: MailPoet - emails and newsletters in WordPress » Error, MailPoet requires a PDO_MYSQL PHP extension

  • Resolved UgoDimma

    (@lovecoinz)


    Hey

    I installed this plugin on my multi site network and network activated it, but it throws the below error on all the site on the network which makes the plugin not to work.

    MailPoet Error: MailPoet requires a PDO_MYSQL PHP extension. Please read our instructions on how to resolve this issue.

    My site is hosted on digitalocean cloud, ubuntu 18.04 running easyengine

    When the error appeared, I went and install the extension and enable it, which now shows up on my phpinfo as you can see on the screenshot here https://nimb.ws/U4NHjS if I’m not mistaken. But the plugin still reported that the extension is not installed or enabled.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter UgoDimma

    (@lovecoinz)

    Issue resolved!

    I have to go to the php.ini and enable it after installation.

    But now, here is a notice I got on my dashboard after network activating the plugin

    We noticed that you’re using an unsupported environment. While MailPoet might work within a MultiSite environment, we don’t support it.

    What’s the possible danger ahead?

    • This reply was modified 11 months, 3 weeks ago by UgoDimma.
    Plugin Author MailPoet

    (@wysija)

    Hi @lovecoinz

    There are several features that are not compatible with Multisite environments. The most important one is the fact that all your WordPress Users from all your WordPress websites are going to be visible to the entire network. That’s the most important one that must be considered.

    Thread Starter UgoDimma

    (@lovecoinz)

    This is terrible!

    That is to say, the owner of sub1.site.com will see the subscribers of sub2.site.come even when they are not subscribed to sub2.site.com?

    If that be the case, is it when network activated or even when activated per site?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error, MailPoet requires a PDO_MYSQL PHP extension’ is closed to new replies.