Support » Plugin: Wordfence Security - Firewall & Malware Scan » Error.log filling up with incorrect integer error from WordFence

Viewing 6 replies - 1 through 6 (of 6 total)
  • I edited out the domain, as the site is not open to the public yet, so it says REPLACED.com instead.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @ghoush Please do not post log data like that here, it doesn’t work after ~10 lines or so.

    If you need share that data please use https://pastebin.com/ instead and post the link to that paste.

    Got it! Here is the log:

    https://pastebin.com/umaTxAxU

    Plugin Support wfdave

    (@wfdave)

    Hi @ghoush,

    Can you let me know your MySQL version? In version 5.7, strict mode is enabled by default.

    Run the query:

    show variables like 'sql_mode';

    If it shows STRICT_TRANS_TABLES, then go into my.cnf and remove it out.

    For example:

    [mysqld] 
    sql_mode = NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES

    Into

    [mysqld] 
    sql_mode = NO_ENGINE_SUBSTITUTION

    Dave

    CycloneBT-Scott

    (@cyclonebt-scott)

    Hi Dave,

    I’m with Gregg’s hosting provider, and we’re using PXC clustered databases. Everything I’ve seen says making that change on a clustered database server may lead to truncated data and potential data inconsistencies. What’s the chance the code could be revised to provide an integer in that field? Or can you suggest another field type for that field that will satisfy both your needs and the STRICT settings?

    ghoush

    (@ghoush)

    @wfdave just checking in to see if you got that note from my host.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error.log filling up with incorrect integer error from WordFence’ is closed to new replies.