• Hi,

    I’m getting some error log warnings related to Slide Anything:

    [19-Apr-2021 15:10:20 UTC] PHP Warning:  DOMDocument::loadHTML(): Tag figure invalid in Entity, line: 1 in /home/…/wp-content/plugins/slide-anything/php/slide-anything-frontend.php on line 1209
    [19-Apr-2021 15:10:20 UTC] PHP Warning:  DOMDocument::loadHTML(): htmlParseEntityRef: expecting ';' in Entity, line: 2 in /home/…/wp-content/plugins/slide-anything/php/slide-anything-frontend.php on line 1209

    What should I do?

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author simonpedge

    (@simonpedge)

    I’m sorry, but I cannot replicate these PHP Warnings on my site.
    I’ve switched WP Debug ON, and have tried with PHP versions 7.3 and version 7.4.

    Also, when I view the link you provided, I’m not seeing any PHP Warnings on the page.

    But, you can switch off WordPress Debug and you will not see these warnings – you need to edit the ‘wp-config.php‘ file in your website root folder, and add the following line:
    define('WP_DEBUG', false);
    (add this line just before the ‘/* That’s all, stop editing! Happy blogging. */’ comment line in the ‘wp-config.php’ file)

    For more info on WP debugging see:
    https://wordpress.org/support/article/debugging-in-wordpress/

    • This reply was modified 7 months, 2 weeks ago by simonpedge.
    Thread Starter Alvaro Gois dos Santos

    (@alvarogois)

    Thanks. I have define('WP_DEBUG', false);, I see the warnings in error_log file.

    Can it be PHP version related? I’m running 7.4 but, as you mentioned, it’s 7.4 tested with no problems. Does the warning itself give you any clues?

    Plugin Author simonpedge

    (@simonpedge)

    No that’s not possible. If you define DEBUG as ‘false’ you are switching WordPress debugging off and WP will not log warnings (or notices).

    These will go to the following file:
    /wp-content/debug.log
    (here’s a useful guide on this: https://themeisle.com/blog/wordpress-error-log-debug/)

    I’m not too sure what this ‘error_log’ file is that you mentioned – it sounds like you may have ‘PHP error logging’ enabled on your hosting – this will be a setting within your hosting control panel.

    Thread Starter Alvaro Gois dos Santos

    (@alvarogois)

    OK, but does the warning itself give you any clues? Thanks.

    Plugin Author simonpedge

    (@simonpedge)

    If you have ‘Remove JavaScript Content‘ or ‘Enable ‘Lazy Load’ Images‘ ticked (under ‘Other Settings’), then try un-ticking them.

    Plugin Author simonpedge

    (@simonpedge)

    The line number in question (1209) is part of the ‘Strip JavaScript’ function.

    Thread Starter Alvaro Gois dos Santos

    (@alvarogois)

    Thanks. Only one of the slides had Remove JavaScript Content option selected. I’ve un-ticked it to see if the notice persists.

    I’ve deleted the error_log file and cleared cache. I don’t see a new error_log file being created yet. It might be it.

    Best,

    Álvaro

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error log entries’ is closed to new replies.