WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Error loading player: No playable sources found

[Resolved] Error loading player: No playable sources found

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author JW Player

    @longtail-video

    What is the shortcode for this post? I don’t see any video being loaded in the source of the page.

    [jwplayer playlistid=”1″ player=”0″]

    Plugin Author JW Player

    @longtail-video

    What is the source of that playlist item in the media manager?

    The file URL is: http://spencermusic.com/wp-content/uploads/2014/03/OverInTheGloryLand.mp3

    The permalink is: http://spencermusic.com/music-samples/overinthegloryland/

    I’m thinking that somehow the playlist is pulling from the permalink and not the file URL??

    Plugin Author JW Player

    @longtail-video

    Yeah, that might be, as the permalink is just a page, not the actual mp3 file.

    I would try this shortcode:

    [jwplayer file=”http://spencermusic.com/wp-content/uploads/2014/03/OverInTheGloryLand.mp3″ player=”0″]

    I’m curious as to what happened. As I mentioned earlier, the player was working wonderfully with the playlist I had created. Something must have happened while I was configuring the rest of the site to change the playlist location, or something to cause it not to work right.

    Regardless, how can I tell where the actual playlist file is located, so that the entire playlist is playing, not just a single song like you have in the shortcode above? Is there a way to link directly to the XML file?

    I even tried deleting an audio or two, creating a new playlist, re-uploaded the songs, but to no avail. It still shows the same error message. I even tried deactivating the JW plugin and reactivating it, along with deactivating all of my plugins and leaving JW Plugin activated. Nothing I’ve tried has made a difference, it still says “No playable sources found.”

    Plugin Author JW Player

    @longtail-video

    You can make an XML file and then do – [jwplayer playlist=”yourplaylist.xml”]

    I think I figured it out…

    I went to the page where I had the shortcode embedded, and deleted the shortcode. From there, I clicked on “Add Media” selected “Insert JWP Playlist”, selected my playlist and clicked on “Insert this player into your post.”

    Everything is working normally again.

    For whatever reason, my playlist ID changed from “1” to something else which was causing the playlist not to load correctly. Weird

    Thanks for your help regardless.

    Plugin Author JW Player

    @longtail-video

    Great, glad you got it, np.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Error loading player: No playable sources found’ is closed to new replies.