Support » Plugin: Advanced Post List » Error loading editor in 0.4.4

  • Resolved GenealogyCoach

    (@samatva)


    Editor broken on three different sites, can’t isolate to a plug-in conflict (I disabled all plug-ins common to the three sites, can’t disable other plug-ins without taking down the sites…).

    Seems to be in the CodeMirror script, near:
    function fg(a,b){function c(){a.value=j.getValue()}if(b=b?k(b):{},b.value=a.value,...
    error = “Cannot read property ‘value’ of undefined”

    All the other places where CodeMirror is used seem to work, e.g. CSS editor, a shortcode editor, etc.

    Went back to advanced-post-list-0.4.2.1-hotfix-notice-review – now works correctly with plain text box editor. 0.4.4.b1 does not fix it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Advanced Post List

    (@advancedpostlist)

    Thank you for reporting this.

    An issue has been opened on Github. https://github.com/Advanced-Post-List/advanced-post-list/issues/126

    Plugin Author Advanced Post List

    (@advancedpostlist)

    The problem should now be resolved with the current update v0.5.0

    Problem con new update Advance Post List V0.5.0!
    the visual editor of wp does not work
    What to do?

    Editor is still broken in Version 0.5.1 – cannot edit any content / before / after list.

    When I click inside the editor box, get the following errors in the dev console:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load[]=-menu,underscore,wp-codemirror&ver=4.9.8:102 Uncaught DOMException: Failed to execute 'removeChild' on 'Node': The node to be removed is not a child of this node.
        at Gb (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:102:17995)
        at Ib (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:102:19528)
        at Ed (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:19665)
        at Bd (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:18094)
        at id (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:10759)
        at gd (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:10240)
        at https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:10146
        at xb (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:102:16263)
        at fd (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:10075)
        at HTMLDivElement.<anonymous> (https://domain.edu/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,jquery-ui&load%5B%5D=-menu,underscore,wp-codemirror&ver=4.9.8:103:12780)
    • This reply was modified 1 year, 10 months ago by GenealogyCoach. Reason: domain

    Editor is still broken in Version 0.5.1 – cannot edit any content / before / after list.

    Oops, marked resolved – started a new thread…..

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error loading editor in 0.4.4’ is closed to new replies.