Support » Plugin: 12 Step Meeting List » Error Linking Plugin to App

  • Resolved eviiaaweb

    (@eviiaaweb)


    I am using the 12 Step Meetings plug in on our website. I have successfully added all the meetings by uploading a .csv file.

    When I click on the “Data source for this website is right here.”, I am getting the following error message {“error”:”HTTP\/1.1 401 Unauthorized”}. This is the link it reveals https://eviaaweb.org/wp-admin/admin-ajax.php?action=meetings

    I am relatively inexperienced in WordPress, but I am fairly tech savvy. I know basic HTML and CSS, a little JS, a little Python etc. I am assuming there is a step I am missing. What is next? We want to be on the App and running our new website very soon. The old site is full of bugs and very outdated.

    New site is located at eviaaweb.org . Meeting searches appear to be functioning well there. The old site is at eviaa.org

    Thanks for taking the time to help us get running. I really appreciate it.

    Matt

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author tech2serve

    (@tech2serve)

    Hi Matt,

    When using the 12-step-meeting-list plugin, you don’t configure the Data Sources section unless you’re aggregating data from different sites. And that is more of an “Advanced Course” concept 🙂

    Instead, look under Settings->Authorized Apps and tell me if you see Meeting Guide shown. If so, and it is shown as a link, you should be able to click on that link and you’ll get a window/tab showing the json feed.

    Assuming you do, the next step should be for you to pull up the Meeting Guide app on a phone and see if your meetings are showing and reflect that they came from you. I am assuming your old site didn’t have a php-based meeting feed to the Meeting Guide.

    • This reply was modified 1 month ago by tech2serve.
    eviiaaweb

    (@eviiaaweb)

    When I pull down the arrow at authorized apps, it has the message “You may allow access to your meeting data for specific purposes, such as the Meeting Guide App.”
    When I click the button to add meeting guide, it takes me to the setting page where it mentions the JSON feeds for aggregating data, the same page I successfully uploaded my .csv on.

    Nothing showing on APP yet.

    Thanks for replying so quickly!

    Matt

    Plugin Author tech2serve

    (@tech2serve)

    Does your section under Authorized Apps (without clicking down the arrow) look like this?

    Please note how Meeting Guide is shown as an authorized app. If it is not showing like the image I provided, you need to type Meeting Guide in the field and click Add.

    Does that make sense?

    eviiaaweb

    (@eviiaaweb)

    Did that. It seems to have worked. I will check the app in a little bit. I needed to type it. Text displayed is a suggestion. A little bit of a “D’oh”!

    Thanks for the help.

    Matt

    Plugin Author tech2serve

    (@tech2serve)

    I’m not sure when AAWS is polling websites, although I understand it is still twice a day. If you don’t see anything pretty soon, you might email them at appsupport@aa.org.

    westmidistrict3aawebmaster

    (@westmidistrict3aawebmaster)

    Sorry, this is probably a stupid questions but I can:t figure out how to authorize the app. There’s no option in settings.

    You need to request authorization from GSO to link your meeting data to the Meeting Guide app. Start here https://meetingguide.aa.org/ and then click the contact us link at the bottom. (“We recommend starting by reading the articles under “Start Here” (above and to the right on desktop, below on mobile), and then, if you’re interested in getting started, please contact us.”)
    https://meetingguide.aa.org/contact

    Good luck!

    • This reply was modified 2 weeks, 5 days ago by lcvincent.
    Plugin Author tech2serve

    (@tech2serve)

    Hi @westmidistrict3aawebmaster,

    There is a step in the settings you need to do to authorize the Meeting Guide app. That is located on the right-hand side of the Import & Settings page under Settings. You should see a section titled Authorized Apps. In that field, enter “Meeting Guide” and click Add.

    At that point, as @lcvincent suggested, contact GSO to have them validate and accept your feed into the broader network.

    If you have further issues, it would be good to start a new thread.

    Thanks, and good luck!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.