Support » Fixing WordPress » Error: Line 151 Error _ Can’t log in

  • So I got booted out after working with Essential Grid for a while (which is the only thing I can think of that happened), and this error appears.

    Warning: require(/home/content/p3pnexwpnas07_data03/26/2599026/html/wp-includes/class-wp-query.php): failed to open stream: Permission denied in /home/content/p3pnexwpnas07_data03/26/2599026/html/wp-settings.php on line 151

    Fatal error: require(): Failed opening required ‘/home/content/p3pnexwpnas07_data03/26/2599026/html/wp-includes/class-wp-query.php’ (include_path=’.:/usr/local/php5_6/lib/php’) in /home/content/p3pnexwpnas07_data03/26/2599026/html/wp-settings.php on line 151

    Any help would be much appreciated as I’m trying to get work done before tomorrow. Thanks.

Viewing 15 replies - 1 through 15 (of 28 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    If you’re with GoDaddy’s Managed WordPress hosting, it sounds like a mistake happened somewhere over there. They are aware of it and working on fixing it.

    The whole “Managed WordPress” aspect puts all of that under only their control, so they’re the only ones who can fix this on their platform.

    Same thing happened here, same line. I will probably try replacing my WP files but does anyone know the reason this happens?

    Same thing here! WTH

    Warning: require(/home/content/a2pnexwpnas02_data01/72/3515972/html/wp-includes/class-wp-query.php): failed to open stream: Permission denied in /home/content/a2pnexwpnas02_data01/72/3515972/html/wp-settings.php on line 151

    Fatal error: require(): Failed opening required ‘/home/content/a2pnexwpnas02_data01/72/3515972/html/wp-includes/class-wp-query.php’ (include_path=’.:/usr/local/php5_6/lib/php’) in /home/content/a2pnexwpnas02_data01/72/3515972/html/wp-settings.php on line 151

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Yes, please see the reply above.

    Please post if anyone has found a solution – this is a clients website – he is on a managed wordpress instance.

    Both staging and live sites are down –
    I still have ftp access to staging and live-
    Im the only one with access to the back end and have not logged in in two days but just noticed today – though i would imagine it hasn’t been this way too long or the client would have called me.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    The solution is to wait for the people behind GoDaddy’s Manage WordPress hosting to correct their deploy of WordPress 4.7.2.

    They are the only ones who control their platform and the only ones who can correct this.

    I have a client hosted on GoDaddy’s managed WP and her site is having the exact same issue. She called support and they said the error is on their end and are working to fix it. There was no ETA.

    Yes, I am also facing the issue. Buy why is Godaddy having similar problems almost every month> Any reasons?

    after 30 minutes on hold i just got the same response as the one posted here –
    They are aware of it and trying to find a resolution….

    basically wordpress is trying to push out updates and of course with managed wordpress by Godaddy they vet the version of wordpress before its updated – apparently and its speculation – it looks like maybe wordpress tried to bypass godaddy vetting and we actually ended up with broken sites (at least on the managed wordpress side of godaddy)

    Of note – all of my other sites not on managed wordpress have had no issues with updates

    • This reply was modified 1 year, 7 months ago by  ryantyre.
    • This reply was modified 1 year, 7 months ago by  ryantyre.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    You’ll have to ask GoDaddy about that, and please let’s not turn this into a thread about which host is better/worse, as we do have to close those down due to the amount of spam they generate.

    I had the same issue, seems to be a general problem with Managed WordPress. I tried to replace class-wp-query.php from the following folder, but no luck.

    • This reply was modified 1 year, 7 months ago by  adsonmacedo.

    It’s back up. Must be a GoDaddy site.

    Hey, the problem was fixed by itself just now, seemed to be a temporary problem.

    I can confirm the issue has been fixed on my client’s site.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Error: Line 151 Error _ Can’t log in’ is closed to new replies.