WordPress.org

Forums

Error "Is its parent directory writable by the server?" Uploading images (34 posts)

  1. sandrosamba
    Member
    Posted 5 years ago #

    hi everyall

    the whole line is:
    "Unable to create directory /mnt/web8/41/24/51413724/htdocs/wp-content/uploads/2009/07. Is its parent directory writable by the server?"

    it appears every time I want to upload an image. Either using the normal uploader either using a plug in.

    What shall I do?

    Thanks

    ALESSANDRO

  2. nazcar
    Member
    Posted 5 years ago #

    url blog/wp-content/uploads

    change the permission of your (uploads) directory to 777

  3. sandrosamba
    Member
    Posted 5 years ago #

    great, how do I do that? where do I have to go? In the wordpress interface within my website/blog? somewhere in the Mysql database?

    thanks
    alex

  4. nazcar
    Member
    Posted 5 years ago #

    if you are using an FTP software like FTP pro or Filezilla right click the folder and select Properties

    http://codex.wordpress.org/Changing_File_Permissions#Using_an_FTP_Client

  5. sandrosamba
    Member
    Posted 5 years ago #

    well, I am on a Mac... Secondly, my wordpress folder does not exit anymore. I mean that I have copied the content of the folder directly in my root directory of the website so that now I can see all the wp-xxxxx files there. I do not know actually to which folder you are referring to.

    thanks ale. I check the link in the meanwhile.

  6. sandrosamba
    Member
    Posted 5 years ago #

    Ok I have done it to index.php now I check if it works

  7. sandrosamba
    Member
    Posted 5 years ago #

    I have changed the properties to indx.php but it does not work. shal I change the permissione to alll the files?
    Isn't it dangerous? Why was it working before without this change in permissions?

    thanks very much
    ALEX

  8. nazcar
    Member
    Posted 5 years ago #

    not the index.php but the folder wp-content/uploads

  9. sandrosamba
    Member
    Posted 5 years ago #

    ok

    I have changed permission recursively to wp-content folder using my FTP software. (cyberduck)

    I have double checked the miscellaneous settings (upload folder: wp-content/uploads)

    Still I receive this message:
    Unable to create directory /mnt/web8/41/24/51413724/htdocs/wp-content/uploads/2009/07. Is its parent directory writable by the server?

    Thanks for you kind effort
    alex

  10. sandrosamba
    Member
    Posted 5 years ago #

    One last detail more. I have installed wordpress 2.8 brand new.

    Before that I have erased the old versione, cleared the databse.

    It is totally new

    tnx
    alex

  11. S.K
    Member
    Posted 5 years ago #

    The default WordPress doesn't contain the "uploads" directory inside wp-content directory. You'll have to create it manually and change its permission to 777.

    That is the only solution.

    S.K

  12. sandrosamba
    Member
    Posted 5 years ago #

    Thanks Kichu I have done it too.

    I have created the folder uploads under wp-content

    I have changed permission recursively to wp-content folder using my FTP software. (cyberduck)

    I have double checked the miscellaneous settings (upload folder: wp-content/uploads)

    It' is puzzling but... still this message:
    "Unable to create directory /mnt/web8/41/24/51413724/htdocs/wp-content/uploads/2009/07. Is its parent directory writable by the server?"

    thanks all
    ALEX

  13. S.K
    Member
    Posted 5 years ago #

    Have you made sure that the "uploads" directory's permission is shown as 777 after you carried out the change - check the properties of that folder.

    Instead of changing the permission of wp-content folder, try changing the permission of the "uploads" directory itself.

    S.K

  14. sandrosamba
    Member
    Posted 5 years ago #

    Yes I have made sure that the "uploads" directory's permission is shown as 777. I directly changed the permission rules for that particular folder.

    I have created the folder uploads under wp-content

    I have changed permission recursively to wp-content folder using my FTP software. (cyberduck)

    I have changed permissions to "uploads" directory.

    I have double checked both wp-content folder's permission (777) as well as uploads folder's permissions (777)

    I have double checked the miscellaneous settings (upload folder: wp-content/uploads)

    Still the same error....

    sorry, it is puzzling
    thanks
    ALEX

  15. S.K
    Member
    Posted 5 years ago #

    Go to miscellaneous settings and uncheck the option "Organize my uploads into month- and year-based folders" and try uploading images.

    Meanwhile register a support ticket with your web host, just in case!

    S.K

  16. frioman
    Member
    Posted 5 years ago #

    I have the same exact problem? I've read the string of posts and tried the same stuff. Still, I'm unable to upload a photo? Any suggestions?

  17. sjogro
    Member
    Posted 5 years ago #

    hey i think i've got the same problem: i was migrating one wp installation to another, i thought i'd manually move the uploads folder from my old server install to my new server install.
    after moving the uploads folder i wanted to import my exported xml and i get this same error:

    Unable to create directory /Users/sjogro/Sites/wp-content/uploads/2009/09. Is its parent directory writable by the server?

    chmodded the uploads 777, no change.

    wait a minute... as I paste this I realize WP is looking in a wrong folder to upload. It should be /Users/sjogro/Sites/wordpress/wp-content/uploads/2009/09...!!

    how do I fix this ??

  18. sjogro
    Member
    Posted 5 years ago #

    solved it, don't know exactly how. since i had a backup of my posts i deleted my wordpress mysql database through phpmyadmin, then created a new. now it works. dont know what the problem was..

  19. aqb
    Member
    Posted 5 years ago #

    I have the same problem when I try uploading a photo, does anybody know how to solve it?

  20. gautam_hn
    Member
    Posted 5 years ago #

    I had the same problem and I found a fix that works for me :

    parent directory writable by the server problem

    Hope this helps some of you folks.

    Cheers,

  21. TRLocke
    Member
    Posted 5 years ago #

    That fix does not work for me. Neither does resetting the permissions. Any help?

  22. TRLocke
    Member
    Posted 5 years ago #

    Okay, guys. This note from Nabeel is all I needed to fix this. I didn't need to change permissions (I spent over an hour trying all that stuff last night and changing them back for safety). Also didn't need to contact my host or anything. There was simply a slash in front of the directory in the default section under Settings, Miscellaneous. Removed the slash and the pictures posted. Thanks Nabeel. Here's the note from him to another user:

    hello tan,

    please make sure it is “wp-content/uploads” and not “/wp-content/uploads”

    waiting to know if it was still not solved.

    My default had the slash in front. Amazing. I didn't need to change permissions or anything.

    TRL

  23. kmessinger
    Moderator
    Posted 5 years ago #

    And what is really absolutely mind-boggling amazing is that it is all in the sticky, right here, this forum, this subject.

  24. azarmig
    Member
    Posted 5 years ago #

    Guys,
    Listen to TRLocke!
    After making sure the permissions are right, just remove the damn "/" from “/wp-content/uploads” in your Settings -> Miscellaneous settings!

  25. mmaattee
    Member
    Posted 5 years ago #

    sorry but all of these solutions do not work for me.

    still getting this problem:

    Unable to create directory \wp-content\uploads. Is its parent directory writable by the server?

    i have tried to change permissions, i have checked and doublechecked the upload folder, slashes, no slashes. whatever!

    i'm really desperate, also because my blog worked fine in october and it doesn now!! could it be something that my Host changed in their settings? Thanks for your help!

  26. Garlic Confit
    Member
    Posted 5 years ago #

    ok. so this has taken me:

    3 days
    100's of blog posts, forum entries.

    If this helps anyone then great.

    Even though I had set permissions for folders to 777 there wasstill the same error of not being able to create/move file to uploads/2009 - it did not matter what I did - delete files, recreate them in FTP.

    In the end I had to create the Folder w-pcontent/uploads (or whatever you want to specify it as in the misc settings page) manually in my DB manager (plesk)and NOT via FTP. This is due to the pache server creating the folder via FTP and not me - therefore different OWNER.

    So in essence do not create the folder via FTP d it manually on your DB.

    Phew. Sorted now I can do the simple job of blogging.

  27. The Sandeep Goyal
    Member
    Posted 5 years ago #

    Great job TRLocke. Thanks..
    It really works..

  28. x3xd
    Member
    Posted 5 years ago #

    TRLocke, thank you

  29. junaidkhawaja
    Member
    Posted 5 years ago #

    Great Job..... TRLocke.

    It Works And I am Very Happy Thanks You So Much....

    Thankyou..
    Thankyou..
    Thankyou..
    Thankyou..

  30. junaidkhawaja
    Member
    Posted 5 years ago #

    I want to Kiss TRLocke....
    He Is Genius...

    http://www.funmela.zzl.org

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.