Support » Plugins and Hacks » [Resolved] Error: invalid_request Missing required parameter: client_id

[Resolved] Error: invalid_request Missing required parameter: client_id

Viewing 7 replies - 1 through 7 (of 7 total)
  • Trying to solve this I did it creating my own project and I now get this error message (not sure if the fact that is a different error message should I open a different threat):

    Error: redirect_uri_mismatch
    The redirect URI in the request: urn:ietf:wg:oauth:2.0:oob did not match a registered redirect URI

    Plugin Author Alin Marcu


    That’s because your are not configuring the API project properly. And secondly, why are your using your own API Project? This is only for developers or education purposes!

    Thank you for your email. Yes second that is the reason for second error that came out after finding alternatives so let’s go back to initial error. What do you suggest?

    I’m trying to see analytics in dashboard but I’m asked to get a code and that is giving me client id error

    You are totally right…, you can just close this ticket now. Things are fixed and working fine.


    I installed and activated Google Analytics Dashboard for WP.

    When I go to the dashboard there is a Google Analytics Dashboard metabox.

    In the metabox it says:

    Use this link to get your access code: Get Access Code

    When I click the link Get Access Code

    I get a page with this:

    – – –

    Error: invalid_request
    Missing required parameter: client_id
    Learn more
    Request Details
    scope=https://www.googleapis.com/auth/analytics.readonly https://www.googleapis.com/auth/analytics

    – – –

    I’m not trying to do any developer or education things, or trying to configure any API project. I’m simply trying to use the plugin.

    How can I get an access code if the link fails?

    BTW – I’m using a browser which is also logged into my GA account right now–so there should be no issues with that connection.

    Probably you have not realized (that was happening to me) that you are (unconsently) doing it as developer, just go back to the basics….

    You don’t have to go to that area where you are finding those fields, doing that you are (without knowing it) setting up the developer area.

    Sorry I can’t be more specific I’m just on my ipad now and don’t have access to site where I set it up but hope this helps… Just get started again, don’t fill in that area…

    Plugin Author Alin Marcu


    Is this option: use your own API Project credentials selected? If yes just deselect it and proceed with the authorization.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Error: invalid_request Missing required parameter: client_id’ is closed to new replies.