Support » Plugin: WP Hide & Security Enhancer » Error Internal links to the pages

  • Resolved woodypad

    (@woodypad)


    Hello,
    I installed your plugin and everything seemed to work.
    Looking and browsing the site seems to work, but clicking on the links inserted into the pages, like buttons, there is a problem.
    In fact if you click on the button the browser does not reach the page shows a blank page with the message
    “Safari can’t find the server, safari can’t open the page because it can’t find the” wp-content “server
    In other cases, a different page is reached than the one entered.
    Why does this happen from what is caused? is there a setting to disable?
    I tried to disable the “wp-content” command in the plugin but nothing has changed.

    I tried to disable the plugin and delete the content inserted by the plugin in the .htaccess file.
    But nothing the site does not return to the previous version.

    How do I solve it?

    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • woodypad

    (@woodypad)

    Now I have also deleted the plugin.
    I have also deleted the data that is saved in the .htaccess file
    Nothing is not solved…

    Plugin Author tdgu

    (@tdgu)

    Hi,
    It should be a cache thing, try to clear the site cache also the CDN cache if use such thing. Lastly it might worth doing the same for your browser.
    If for some reason still not working, consider to contact us and provide additional help.

    Thanks

    woodypad

    (@woodypad)

    I have already deleted the site cache and the browesr cache several times. But nothing happens those links remain incorrect.
    Didn’t you say that nothing changes in the database?

    I also made a copy of the site, I also tried deleting the plugin and reinstalling, but nothing …

    I wanted to use your plugin, but unfortunately it creates permanent problems.

    I decided to restore all the links by hand, it seems to work, I hope the database has not been compromised.
    Do you have a suggestion to clean it up?

    woodypad

    (@woodypad)

    In reality, only now I realize that there are other errors.
    Some images are missing, and allows you to see the preview of pages and posts and when you are on the front end as an administrator there is no bar above to return to the site …
    A big mess!

    Plugin Author tdgu

    (@tdgu)

    Since when you use our plugin?

    woodypad

    (@woodypad)

    I tried several times to use it for a few years, I always tested it on test sites, but in the end I always gave up using it because it always caused me some problems.
    This time last week I wanted to install it on a site just finished online, I also read that it was enough to delete the data written in the .htaccess file, then I convinced myself to use it.
    It was a mistake unfortunately …
    I like your plugin seems well thought out, but it creates problems.
    Maybe it can conflict with other plugins or themes?
    He has always given me problems with any theme or plugin installed.

    Maybe it should be installed before developing the entire website?
    I’ve always used it at the end when everything is ready.

    Plugin Author tdgu

    (@tdgu)

    This should really work fine, as long your server run Apache or Nginx set as reverse proxy for Apache (using .htaccess) or IIS. The plugin inform through a message, on top of page, if the server is not supported, in such case no rewrite is applied so the site should work the same as before.

    Conflicts with other plugins are really rare, as contrary to what many people expect, the plugin actually work with outputted HTML (99%) and not by interacting with other plugins(1%).
    Giving that, the issues are a result of two main tings:

    1) Cache issues – there’s an active cache, either for the site, for the server or CDN (if use such thing). Blocking default urls through the plugin, but not clearing the cache, makes the default files required on front side (e.g. css, javascript, images) to not load anymore.

    2) Rewrite problems – the server environment is not correctly set-up to run such Apache rewrite (e.g. LiteSpeed Web Server supports the Apache .htaccess, but if not configured through the admin panel to load the file, it will not work).

    Also the plugin does not change anything on the server side, either on files, directory structure, database. Everything is processed on the fly. So will be enough to de-activate the plugin and everything will restore as before. If de-activate is not possible (e.g. admin access is not possible for whatever reason), the plugin delete from server and rewrite remove from .htaccess will be enough to restore the site to previous. If the outputted html still contain modified urls, that means it loads the data from a cache, try to clear that.

    I’am pretty much sure your problems are related to above, so please check on that.
    He has always given me problems with any theme or plugin installed. Can you describe which where the issues?

    As always, i can help further with this, also feel free to contact us if can’t figure out.

    Thanks

    Hello,
    I don’t want to be controversial, I would love to use your plugin.

    As I said, I deleted the wordpress cache, the server cache and the browser cache. nothing the situation does not change.
    I also made a copy of the site on another test domain, same situation.
    It seems to have changed the addresses of some links on the pages, among other things, I also noticed a strong slowdown.

    Fortunately I had a backup unfortunately not too long and I recovered the main site.
    If you want I can provide access data to the test site, if you want to have a look, but only out of curiosity.

    Thank you

    Plugin Author tdgu

    (@tdgu)

    Hi,
    Yes i would love to check it out. Can you please send a message through our contact at http://www.wp-hide.com?

    Thanks

    Hi,
    sent, I’m waiting.
    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.