WordPress.org

Support

Support » Plugins and Hacks » CSV 2 POST » [Resolved] Error installing

[Resolved] Error installing

  • Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/usr/local/php5/lib/php/PEAR.php) is not within the allowed path(s): (/home/***/:/tmp/) in /home/***/domains/***.com/public_html/wp-content/plugins/csv-2-post/include/pear/File/CSV.php on line 25

    How can I solve this?

    http://wordpress.org/extend/plugins/csv-2-post/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WebTechGlobal

    @webtechglobal

    Hello

    Seems your server/hosting has a restriction effecting PEAR CSV.

    We have stopped using PEAR CSV functions in some of the plugin. We may need to just phase it out totally as PHP itself (fgetcsv for example) is a lot better these days.

    You could run it past your hosting. The restriction may be lifted however I’m still making it a priority error to investigate at our end and make required changes.

    Thank you for trying CSV 2 POST.

    Plugin Author WebTechGlobal

    @webtechglobal

    What hosting are you using?

    I’m now on the case and can confirm the restriction is applied for security. Your the first to come to me with the issue so I’m wondering what hosting is applying it. It could always be a recent change in their .ini though.

    A 25% discount on the premium edition is available to yourself for being the first to report this. A further 25% will be giving after I release a fix and you respond with the results.

    Changes are always tweeted @CSV2POST

    RSS feed links are on the plugins main pages also.

    I will try to get it fixed quickly.

    Plugin Author WebTechGlobal

    @webtechglobal

    GoDaddy page on open_basedir seems to suggest they allow it to be switched off. Not suggesting it is the long term solution but may be a temporary one especially if your working on a test installation…

    http://support.godaddy.com/help/article/1616/what-is-openbasedir

    The change to fgetcsv() is complete. You should no longer get this error.

    If you are interested in a 50% discount for the premium edition please see here.

    I’m only mentioning this because an offer was made above for 25% and today this new offer come about. I wouldn’t want you buying and missing a further 25%. However the terms are that you would get a nightly build suitable for WordPress 3.6 only, as explained on that page.

    The new version coming will improve the free edition as always so purchase is not required. We will continue improving the free edition and are open to requests on how to improve it.

    OK, thanks. Since I did not have much time to wait for a solution I used another plugin which worked fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Error installing’ is closed to new replies.
Skip to toolbar