WordPress.org

Support

Support » Installation » error in WP update to 3.3.

error in WP update to 3.3.

  • Y updated automatically to 3.3. and am now getting this warning (repeated many times):

    Warning: strpos() [function.strpos]: Empty delimiter in /home/mienreda/public_html/wp-includes/user.php on line 699

    Please Help!

    jimmy

Viewing 7 replies - 1 through 7 (of 7 total)
  • files missing, not everything was uploaded to have wordpress run.
    You probably cant even get in the backend. If you have FTP try manually to make sure that all files are uploaded. Did you first deactivate all plugins?

    Moderator keesiemeijer

    @keesiemeijer

    Can you still log in?

    Do you have define('WP_DEBUG', false); set to true in your wp-config.php, if so set it to false.

    read the troubleshooting 3.3 master list for steps you can take: http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    Rainer2: I can get in the back end fine, my dashboard is an absolute mess, though; can barely understand it. It doesn´t (as far as I can tell) seem to be affecting the site itself, though. Tried deactivating all plugins and reinstalling: same effect.

    keesiemiejer: I can log in. Checked wp-config, and its set to false. Checked the master list and nothing there seems to address my problem.

    I went to the user.php file mentioned in the warning and this is what it says: ” if ( 0 !== strpos( $key, $wpdb->base_prefix ) ) “

    I have no idea what that means; its all PHP to me. Ideas, anyone?

    Moderator keesiemeijer

    @keesiemeijer

    Have you tried:

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    – re-uploading all files & folders – except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides. (manual upgrade)

    – re-running the upgrade via wp-admin/upgrade.php

    So it seems that backend and frontend work fine. Looks you had the same before, http://wordpress.org/support/topic/plugin-group-documents-warning-division-by-zero-1?replies=1 when upgrading to 3.1.1. Try to deactivate buddypress. Dashboard in absolute mess, what exactly is the the error message?

    Keesimeijer:
    – no idea what “flushing caching plugins” even means,much less how to go about doing it, sorry.
    – had already tried deactivating plugins – didn´t work.
    – switched to default theme – didn´t work.
    – leaving manual upgrade as last resort: am new at this.
    – tried rerunning the upgrade, didn´t work.

    Rainer23:
    – no, its not like the division-by-zero warning I got before; that was a plugin.
    – deactivated buddypress and all other plugins, didn´t work
    – recap: the warning says:
    Warning: strpos() [function.strpos]: Empty delimiter in /home/mienreda/public_html/wp-includes/user.php on line 699
    Line 699 in my wp/includes/user.php says:
    if ( 0 !== strpos( $key, $wpdb->base_prefix ) )

    Moderator keesiemeijer

    @keesiemeijer

    – no idea what “flushing caching plugins” even means,much less how to go about doing it, sorry

    If you don’t have any cache plugins running, you don’t need to flush them.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘error in WP update to 3.3.’ is closed to new replies.
Skip to toolbar