Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Error in WP 3.5: Missing argument 2 for wpdb:

Viewing 10 replies - 1 through 10 (of 10 total)
  • shammah


    I just got the same message when I updated to 3.5:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/sham8551/public_html/wp-content/plugins/nextgen-gallery/lib/tags.php on line 318 and defined in /home/sham8551/public_html/wp-includes/wp-db.php on line 990

    and have no idea what to do! I am hosted on my own website using WP.




    Forum Moderator

    Don’t panic. The front end of your site and the plugin should continue to work correctly but you will have to wait for this plugin to be updated before that warning in the back end disappears.

    I did some reading on it and it looks like NOT a big deal and an update to the plugin will fix it. Just wait for that.

    OT: Maybe one of these days WP will have the option to REVERT after an upgrade if you encounter problems because I sure don’t have time to back up every site. I don’t understand how these errors happen after numerous betas and release candidates and this is NOT the only plugin affected.

    Just saw esmi’s post. The error seems to show on every post here:



    This error message is clearly visible to the Public…and gives them too much info about my site and where things are found….i.e. the url to get in to the site? I don’t like it being up and out there.



    Forum Moderator

    I don’t understand how these errors happen after numerous betas and release candidates and this is NOT the only plugin affected.

    Unfortunately not all plugin developers take the time to test their plugins with the next beta release of WordPress – even though they had about 6 months of beta testing time with this core update.

    Even when plugins are tested, it’s possible that an obscure bug can slip through.

    If you are seeing the error message on the front end of the site, then you should ask your hosts to suppress PHP warning – as most good hosts already do for security reasons.

    Once again it’s MY FAULT! I shoulda known. Just this morning my VPS host SolaDrive told me that my VPS had high loads at around 5 am due to the wordpress index.php and that I need to have the developers make some changes (my combined WP sites had a total of 70 page views by 9 am).

    I’m getting awfully sick of the fingerpointing!

    I suppose I’ll just disable NextGen Gallery and use something else. I regret the donation I had made.

    Plugin Author photocrati


    Hey everyone,

    Please refer to this forum thread already created that addresses this bug, and provides a temp. fix until we release an upgrade:



    My fabulous webhost,, who allows you to call them just turned off the message so it no longer shows on my pages. when the upgrade comes in it will fix it without my having to do anything. So maybe your host can turn it off or tell you how.

    My awful host SolaDrive just got most of my sites working yesterday after a life altering move and two weeks in SolaDrive HELL. It’ll take me at least several weeks to recover (emotionally and financially) and quickly moving to some other host isn’t an option.

    So, disabling NextGen did NOT work. Since there is no “delete” button for NextGen, I had to ftp and delete the plugin. That did the trick.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error in WP 3.5: Missing argument 2 for wpdb:’ is closed to new replies.