Support » Plugin: WooCommerce » error in woocommerce in V5.5 Wp

  • Resolved Matin Beigi

    (@mrbeigi)


    Fatal error: Declaration of Automattic\WooCommerce\Internal\DependencyManagement\ExtendedContainer::get($id, bool $new = false) must be compatible with League\Container\Container::get($alias, array $args = Array) in /home/cp39996/public_html/wp-content/plugins/woocommerce/src/Internal/DependencyManagement/ExtendedContainer.php on line 113

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter Matin Beigi

    (@mrbeigi)

    It turns out that the same problem with me and this just happened, how do I fix it? please someone willing to answer

    ExtendedContainer::get($id, bool $new = false) must be compatible with League\Container\Container::get($alias, array $args = Array) in

    Same error for me.

    Admin

    (@princeanskhan)

    Same with me. It crashed my website

    aha

    Guys, I had the same Problem today and here is a quick solution that I did in 3 minutes and everything is working fine for me.

    Go to this link: https://wordpress.org/plugins/woocommerce/advanced/
    Download the version of woocommerce 4.3.3

    Go to your wordpress dashboard. Upload the plugin. Do not delete the old plugin because I don’t know either your data will be lost or not so the way which I am telling is totally safe.
    Now When you upload the plugin, WordPress will ask you to replace with current version. Click on that and your system will start working fine. If you have any questions regarding this solution feel free to ask.

    Thanks

    Plugin Support RK a11n

    (@riaanknoetze)

    Hi there,

    Just to make sure – are you using WP Rocket by any chance? I’m asking as there’s been several reports where WP Rocket’s dependency injection method isn’t compatible with the latest version of WooCommerce.

    More information at: https://github.com/woocommerce/woocommerce/issues/27384

    I got the error and am not using WP Rocket on the site.

    Fatal error: Declaration of Automattic\WooCommerce\Internal\DependencyManagement\ExtendedContainer::get($id, bool $new = false) must be compatible with League\Container\Container::get($alias, array $args = Array) in /wp-content/plugins/woocommerce/src/Internal/DependencyManagement/ExtendedContainer.php on line 18

    P.S. For anyone who’s website is broken, look for an email sent to your admin email address for recovery mode to deactivate the plugin until the issue is fixed.

    Jeff D

    (@twogringosmedia)

    They finally released an update. Not in the regular channels, yet, but it’s on Github where they develop it. It works for me.
    https://github.com/woocommerce/woocommerce/releases/tag/4.4.1

    Here’s wah happened and what the fixed/disabled to get it to work for now: https://github.com/woocommerce/woocommerce/blob/master/src/README.md

    Plugin Support Steve E.a11n

    (@woosteve)

    Automattic Happiness Engineer

    Just to confirm, WooCommerce 4.4.1 has now been released, and updating to this version will solve the issues mentioned above.

    I’ll go ahead and mark this thread as solved but please feel free to start a new thread if you see any additional problems.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘error in woocommerce in V5.5 Wp’ is closed to new replies.