Support » Plugin: WP Super Cache » Error in V1.6.1 in shared hosting environments (open_basedir restriction)

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have a similar problem.

    Debug:

    Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058 Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058 Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058 Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058
    Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058
    Fix problems with the plugin by debugging it here. It will log to a file in your cache directory.

    Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058 Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058 Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/home/viajesloreto.com/:/home/viajesloreto.com/:/usr/home/services/) in /usr/home/viajesloreto.com/web/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1058

    Same problem as Bosco

    Ditto.

    I am using PHP-FPM with a dedicated user for the pool. After reading, it sounds like I might be able to workaround this issue by setting the TMPDIR environmental variable in my pool config, but I don’t feel like this should be necessary or at a minimum the error WPSC error message is misleading.

    Is it really necessary to block modifying of any files and consequently break the plugin because a temporary file can’t be created at /tmp ?

    • This reply was modified 3 years, 7 months ago by bdelamatre.

    Is there any solution?

    Please!

    I downloaded version 1.6.0 from here: https://plugins.trac.wordpress.org/browser/wp-super-cache/tags?order=name#1.6.0
    I’ve replaced it by 1.6.1 and seems to work again

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Can you give the development version of the plugin a go? The config file code is back to the way it was before so this error is gone. I’m hoping to release a new version next week.

    Get the development version at: http://ocaoimh.ie/y/2o

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error in V1.6.1 in shared hosting environments (open_basedir restriction)’ is closed to new replies.