Support » Plugin: License Manager for WooCommerce » Error in the most recent version

  • Resolved Darko G.

    (@darkog)


    Hello,

    Just wanted to report error in this new version.

    I am using PHP 7.0.

    An error of type E_PARSE was caused in line 12 of the file /home/USR/public_html/wp-content/plugins/license-manager-for-woocommerce/includes/Migration.php. Error message: syntax error, unexpected ‘const’ (T_CONST), expecting variable (T_VARIABLE)

Viewing 1 replies (of 1 total)
  • Plugin Author Drazen Bebic

    (@drazenbebic)

    Hello @darkog,

    thank you for your message and for using my plugin.

    You are correct, I can’t believe I missed this…

    I’ll patch this for the next release, until then you could simply edit the following file:

    wp-content/plugins/license-manager-for-woocommerce/includes/Migration.php

    On lines 12 and 17 remove the “public” keyword, the result should be like:

    line 12: const MODE_UP = 'UP';
    line 17: const MODE_DOWN = 'DOWN';

    That should do the trick for now until it’s fixed. Thanks again for reporting the issue.

Viewing 1 replies (of 1 total)
  • The topic ‘Error in the most recent version’ is closed to new replies.