Support » Installing WordPress » error in step 2

  • Resolved pmartinozzi

    (@pmartinozzi)


    Goodmornin everybody
    I ve got soe trouble n my wordpress installation.
    Everything looks working until I arrive on the page where I should insert my database info. Once I fill the form and I submit the information I ve got a white page with no information if I use firefow and an error 500 if I use chrome.
    I think it s the step for the creation of the file wp-config.
    I tried as well to create the file by myself editing manually the db information but apparently it doesnt work either…someone can help me?

    • This topic was modified 2 months, 1 week ago by  stephencottontail. Reason: removing modlook tag

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • pmartinozzi

    (@pmartinozzi)

    then if I create the wp-config manually and I link to:
    http://localhost:8080/p_wp/index.php

    I got this error:
    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\Apache24\htdocs\p_wp\wp-includes\wp-db.php:1570 Stack trace: #0 C:\Apache24\htdocs\p_wp\wp-includes\wp-db.php(658): wpdb->db_connect() #1 C:\Apache24\htdocs\p_wp\wp-includes\load.php(404): wpdb->__construct(‘dbUser’, ‘dbPassword’, ‘dbName’, ‘localhost’) #2 C:\Apache24\htdocs\p_wp\wp-settings.php(106): require_wp_db() #3 C:\Apache24\htdocs\p_wp\wp-config.php(89): require_once(‘C:\\Apache24\\htd…’) #4 C:\Apache24\htdocs\p_wp\wp-load.php(37): require_once(‘C:\\Apache24\\htd…’) #5 C:\Apache24\htdocs\p_wp\wp-blog-header.php(13): require_once(‘C:\\Apache24\\htd…’) #6 C:\Apache24\htdocs\p_wp\index.php(17): require(‘C:\\Apache24\\htd…’) #7 {main} thrown in C:\Apache24\htdocs\p_wp\wp-includes\wp-db.php on line 1570

    pmartinozzi

    (@pmartinozzi)

    pls somebody helps me I m getting crazy around this stuff

    Hoover

    (@ryanshoover)

    Looks like your localhost is running php7.0. And WordPress is trying to connect with mysql_connect instead of mysqli_connect PHP removed mysql in place of mysqli in 7.0

    You might try putting this line in your wp-config.php file:

    define( 'WP_USE_EXT_MYSQL', false );

    That will force WP to use mysqli

    pmartinozzi

    (@pmartinozzi)

    I tried adding that string on the wp-config but I keep having the same result…white page on firefox and error 500 on chrome…I am lost
    everything is runnung ok I can see the page of the language selection and the page of the db configuration but than when I send the form I ve got always the same result as above…same if I modify the wp-config manually

    It looks as if you are trying to install WordPress locally on Windows OS. You should try using XAMPP or WAMP if that is the case.

    Thanks guys I Ve tried with xampp and everything works properly but I still don’t understand because the last setup was not good … I reckon it should work !!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.