WordPress.org

Forums

All in One SEO Pack
[resolved] error in sitemap (8 posts)

  1. mikhak
    Member
    Posted 1 year ago #

    Hi.
    my sitemap display this error :

    XML Parsing Error: no element found
    Location: http://nfliri.ir/sitemap.xml
    Line Number 1, Column 1:

    please help me for solve this problem

    https://wordpress.org/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Hi mikhak,

    I don't see your sitemap there; make sure your Permalink settings are set up correctly, or if that doesn't work, turn off dynamic sitemap generation.

  3. mikhak
    Member
    Posted 1 year ago #

    Hi.

    I removed that file and create a new sitemap file.

    but I have another problem withe sitemaps .

    this error in this page :

    http://nfliri.ir/sitemaps_post_tag.xml

    error :

    XML Parsing Error: syntax error
    Location: http://nfliri.ir/sitemaps_post_tag.xml
    Line Number 2, Column 1:Fatal error: Out of memory (allocated 315359232) (tried to allocate 86 bytes) in /home/mikhakne/domains/nfliri.ir/public_html/wp-includes/plugin.php on line 164
    ^

  4. Hi mikhak,

    Try increasing the memory allocated to WordPress by following the instructions here - http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

  5. mikhak
    Member
    Posted 1 year ago #

    Hi,

    Thank you for help me . ( Peter Baylies and wpsmort )

    but

    I increasing the memory limit to 1024Mb but my problem not solve :

    in wp-config:

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    define( 'WP_MEMORY_LIMIT', '1024M' );
    define( 'WP_MAX_MEMORY_LIMIT', '1024M' );

    and in WP-settings :

    <?php
    /**
     * Used to set up and fix common variables and include
     * the WordPress procedural and class library.
     *
     * Allows for some configuration in wp-config.php (see default-constants.php)
     *
     * @internal This file must be parsable by PHP4.
     *
     * @package WordPress
     */
    
    /**
     * Stores the location of the WordPress directory of functions, classes, and core content.
     *
     * @since 1.0.0
     */
    define( 'WP_MAX_MEMORY_LIMIT', '1024' );
    define( 'WPINC', 'wp-includes' );
    
    // Include files required for initialization.
    require( ABSPATH . WPINC . '/load.php' );
    require( ABSPATH . WPINC . '/default-constants.php' );

    my host allows to 1024 Mb

    please help for solve this problem .

  6. mikhak
    Member
    Posted 1 year ago #

    Anybody wants to help me?

  7. mikhak
    Member
    Posted 1 year ago #

    Anybody wants to help me?

  8. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Hi mikhak,

    That should be 1024M not 1024 - just specifying 1024 means 1024 bytes, not megabytes. Does your memory error reflect the increased amount of memory, because nothing on your site should be using 1024M aka megabytes of memory.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All in One SEO Pack
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.