Support » Plugin: Events Manager - Email Users » Error in plugin settings

  • Hi Patrick,

    I’m getting this error when using Events Manager – Email Users (4.1.4). It first occured when I changed the “Apply to all EM Emails” setting.

    Fatal error: Uncaught Error: Call to undefined method Stonehenge_Plugin::load_assets() in /homepages/36/d41694676/htdocs/wp-content/plugins/events-manager-email-users/config/more.php:34 Stack trace: #0 /homepages/36/d41694676/htdocs/wp-includes/class-wp-hook.php(286): Stonehenge_More_Plugins::show_this_page('') #1 /homepages/36/d41694676/htdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #2 /homepages/36/d41694676/htdocs/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /homepages/36/d41694676/htdocs/wp-admin/admin.php(253): do_action('stonehenge_page...') #4 {main} thrown in /homepages/36/d41694676/htdocs/wp-content/plugins/events-manager-email-users/config/more.php on line 34

    In addition to that, the “Add Plain Text Version” setting is only showed sometimes. Most of the time, it’s not even there. Maybe it has something to do with this setting.

    OT: What is the difference between the plain text version that can be added at this place and the code you’ve posted here?

    Thank you very much!

    • This topic was modified 1 month, 3 weeks ago by fabian96.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Patrick

    (@duisterdenhaag)

    It seems you are mixing up things…

    That error was there, BUT not where you claim. That part of the code is only called when you click the “More” sub menu item. It had nothing to do with the toggle you mentioned. It has been resolved in the already released update.

    Also, “Add Plain Text” is only shown if you have set “Apply to All Emails”, meaning using the credentials above that toggle also to the native booking emails.

    That option is extremely useful for WordPress MultiSite users, as EM only allows network-wide email credentials, while a WP MS can have different companies/domain names below it. This option allows MultiSite Admins to finally set the outgoing EM email credentials per blog.

    Only, when you allow this plugin to hook into the native booking emails, you will see the question to add the missing plain text version to those. Clicking the toggle shows/hide the question. Pretty simple.

    The option to add a plain text version is not mentioned anywhere else. So not “sometimes”. All emails constructed by this plugin (so not the booking emails EM sends out) always have the plain text version added, to prevent being marked as spam. It is just that is is a missing option in EM itself, that I added that option. But again, only if you allow the plugin to alter the native EM emails.

    You‘re right concerning the error. I just got this email as I was on the settings page.

    But the plain text option is still not shown although the apply to EM option is activated. If I click on this toggle (without changing it!) suddenly the option will appear. This way the option will also appear if the apply to EM option is deactivated. There seems to be a bug.

    Plugin Author Patrick

    (@duisterdenhaag)

    No it’s not a bug. It is only visible when “Apple to All” = Yes.

    Sounds like you are having a javascript problem. Check your browser console for that.

    I’ve checked my website, it doesn’t have any javascript problem. The bug is still there in the latest version. The plain text option will only be displayed if I click on the “apply to all” toggle (without changing it).

    Plugin Author Patrick

    (@duisterdenhaag)

    IT IS NOT A BUG!

    I will stop now.

    I’d be surprised if that was the intended behavior.

    EM-Email-Users-Bug

    • This reply was modified 1 month, 3 weeks ago by fabian96.
    • This reply was modified 1 month, 3 weeks ago by fabian96.
    • This reply was modified 1 month, 3 weeks ago by fabian96.

    @duisterdenhaag: Have you checked the provided gif?

    Plugin Author Patrick

    (@duisterdenhaag)

    No. IT IS NOT A BUG! I’ve tried to explain to you how it works, but you seem tone that.

    Yes, I’ve understood your explanation how it should work and this of course make sense to me. But it does not really work as you explained as you can see in the gif.

    • This reply was modified 1 month, 1 week ago by fabian96.
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.