Support » Plugin: Cimy Swift SMTP » Error in plugin after update

  • Resolved azurecurve

    (@azurecurve)


    After upgrading the plugin I got this error:
    Parse error: syntax error, unexpected T_OBJECT_OPERATOR in E:\HostingSpaces\username\siteaddress\wwwroot\wp-content\plugins\cimy-swift-smtp\swift_engine.php on line 174

    I had to delete the plugin folder to get the site working again. Downloading and installing the plugin in again produced exactly the same error.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Marco Cimmino

    (@cimmo)

    The new version requires PHP 7.0 or greater, which version do you have?

    Plugin Author Marco Cimmino

    (@cimmo)

    Can you please try v3.0.1? Should contain a fix for that.

    Plugin Author Marco Cimmino

    (@cimmo)

    Sorry v3.0.2 rather should work, anyway I believe you have PHP 5.3 or older, please consider upgrading to PHP 7.0 or later for the best security and performances.

    best
    Marco

    3.0.2 works, thanks.

    I am restricted by my web host as to which version of PHP I can use.

    Hi! After updating to WP 4.9 your plugin does not work anymore. Is there a way to get it back to work?
    All the best,
    Nerissa

    Plugin Author Marco Cimmino

    (@cimmo)

    Hi,
    I tried myself and works for me on 4.9, does the test email work?
    Any error?

    best

    hi I have some issue after I upgrade the wordpress to 4.9

    when I make the test it says

    Test result
    Unable to connect with TLS encryption

    but on the website that I have 4.8.1 is working fine.

    please let me know if someone had the same issue and how to solved it.

    Plugin Author Marco Cimmino

    (@cimmo)

    I haven’t reproduced the problem myself, but thanks, I’ll try to investigate.

    Plugin Author Marco Cimmino

    (@cimmo)

    @sonyapereira send an email to me at cimmino.marco@gmail.com so we can debug further.

    Hi Marco,
    If you can help me, I would very much appreciate it.

    I am stuck for now on PHP 5.3. I have v. 5.02 of your plugin.

    Is it possible to have this error fixed?
    —————————————–
    Parse error: syntax error, unexpected T_OBJECT_OPERATOR in …/wp-content/plugins/cimy-swift-smtp/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Message.php on line 74
    ——————————————–

    Thank you so much.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error in plugin after update’ is closed to new replies.