Support » Fixing WordPress » Error in .php on pluggable.php?

  • Resolved piazawa

    (@piazawa)


    I’m setting up a website for a customer who is using another web host than I usually use. I’m not able to make it run, get this message:

    Warning: Cannot modify header information – headers already sent by (output started at /rgt/207/72911/www/wp-config.php:1) in /rgt/207/72911/www/wp-includes/pluggable.php on line 881

    I haven’t had this problem before. I don’t have Dreamweaver, so I’m not able to see the line number the message is refering to.

    What to do?

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi

    (@esmi)

    Forum Moderator

    piazawa

    (@piazawa)

    I did….but it didn’t help, I’m afraid.

    esmi

    (@esmi)

    Forum Moderator

    And what exactly did you do?

    Kegan Quimby

    (@keganquimby)

    open up the header.php file in the theme. make sure all the calls to the required/included files are in ONE php tag

    <?php include ('path/file1.php'); ?>
    <?php include('path/file2.php'); ?>

    should be

    <?php
    include ('path/file1.php');
    include ('path/file2.php);
    ?>
    piazawa

    (@piazawa)

    This is what I did:

    Download the file mentioned in the error message via FTP or the file manager provided in your host’s control panel.
    Open that file in a plain text editor (NOT MS Word or similar. Notepad or BBEdit are fine).
    Check that the very first characters are <?php
    Check that the very last characters are ?>
    To be sure about the end of the file, do this:

    Place the cursor between the ? and >
    Now press the DELETE key on your computer
    Note to MAC users: The “DELETE” key on a PC deletes characters to the right of the cursor. That is the key noted here.
    Keep that key pressed
    For at least 15 seconds
    Now type > and
    save without pressing any other key at all.
    If you press another key, you will bring the problem back.
    Upload the file back to your server after editing and saving the file.

    piazawa

    (@piazawa)

    Can’t find the header.php…seems to be missing. I use Thesis. Can’t find this file on well functioning sites either

    piazawa

    (@piazawa)

    Maybe the best way is to start from scratch and try again?

    esmi

    (@esmi)

    Forum Moderator

    headers already sent by (output started at /rgt/207/72911/www/wp-config.php:1

    The issue is in wp-config.php – as explained in the page I linked to above.

    Kegan Quimby

    (@keganquimby)

    if you’re using thesis, you should be fine… but header.php is in wp-content/themes/yourthemename/header.php

    but it seems like the problem is in wp-config.php

    piazawa

    (@piazawa)

    Yes, and it’s referring to line 881.

    esmi

    (@esmi)

    Forum Moderator

    No – it’s an issue with line 1 in wp-config.php.

    piazawa

    (@piazawa)

    ok..I look into it later, have to go. Thank you all 🙂

    piazawa

    (@piazawa)

    Line 1 is containing only the opening .php tag:
    <?php

    Can’t see what’s missing. Still doesn’t work.

    piazawa

    (@piazawa)

    Wow! Suddenly it worked :-))

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error in .php on pluggable.php?’ is closed to new replies.