Support » Plugin: Jetpack by WordPress.com » Error in Media-extractor.php

  • Resolved sk_tamilan

    (@sk_tamilan)


    I am getting the following error 16 times on my website. Wierdly enough its only happening on one page

    Notice: Undefined index: scheme in /home/codenath/public_html/wp-content/plugins/jetpack/class.media-extractor.php on line 380
    
    Notice: Undefined index: host in /home/codenath/public_html/wp-content/plugins/jetpack/class.media-extractor.php on line 380

    http://wordpress.org/plugins/jetpack/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    Could you try to reinstall Jetpack from scratch?

    If that doesn’t help, could you point me to the page where you experience the issue?
    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    Hi Jeremy,

    I have tried already tried completely deleting the plugin and re-installing but no avail.

    I have sent a request through the contact form.

    Kind Regards

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    Thanks! We’ll have a look, and I’ll post again here as soon as I have some news.

    Hi Jeremy,

    I have found the cause of the problem. Since i use this template a lot, I am using shorcodes to define the path of my images relative to the template url and this is the cause of the problem.

    [template-url]/img/image.jpg

    the code in media-extractor is trying to process the images prior to wordpress processing the shortcode.

    Fix: Replace with the absolute url of the image like :-

    http://example.com/wp-content/themes/example/img/image.jpg

    I was told by the support team this won’t most likely to get fixed.

    topic closed

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    We’ve now updated Jetpack so it won’t display these notices. You can see the changeset here. The fix will be included in the next Jetpack release.

    Thanks for reporting the issue!

    I’ve now started getting these errors, and removing Jetpack and reinstalling it hasn’t helped. I’m using Jetpack 2.7.

    esmi

    (@esmi)

    Forum Moderator

    @paulcutcliffe: If you require assistance then, as per the Forum Welcome, please post your own topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error in Media-extractor.php’ is closed to new replies.