WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Error in Media-extractor.php (9 posts)

  1. sk_tamilan
    Member
    Posted 1 year ago #

    I am getting the following error 16 times on my website. Wierdly enough its only happening on one page

    Notice: Undefined index: scheme in /home/codenath/public_html/wp-content/plugins/jetpack/class.media-extractor.php on line 380
    
    Notice: Undefined index: host in /home/codenath/public_html/wp-content/plugins/jetpack/class.media-extractor.php on line 380

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to reinstall Jetpack from scratch?

    If that doesn't help, could you point me to the page where you experience the issue?
    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  3. sk_tamilan
    Member
    Posted 1 year ago #

    Hi Jeremy,

    I have tried already tried completely deleting the plugin and re-installing but no avail.

    I have sent a request through the contact form.

    Kind Regards

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks! We'll have a look, and I'll post again here as soon as I have some news.

  5. sk_tamilan
    Member
    Posted 1 year ago #

    Hi Jeremy,

    I have found the cause of the problem. Since i use this template a lot, I am using shorcodes to define the path of my images relative to the template url and this is the cause of the problem.

    [template-url]/img/image.jpg

    the code in media-extractor is trying to process the images prior to wordpress processing the shortcode.

    Fix: Replace with the absolute url of the image like :-

    http://example.com/wp-content/themes/example/img/image.jpg

    I was told by the support team this won't most likely to get fixed.

  6. sk_tamilan
    Member
    Posted 1 year ago #

    topic closed

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    We've now updated Jetpack so it won't display these notices. You can see the changeset here. The fix will be included in the next Jetpack release.

    Thanks for reporting the issue!

  8. PaulCutcliffe
    Member
    Posted 1 year ago #

    I've now started getting these errors, and removing Jetpack and reinstalling it hasn't helped. I'm using Jetpack 2.7.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    @PaulCutcliffe: If you require assistance then, as per the Forum Welcome, please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.