Support » Plugin: Amazon Associates Link Builder » Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden

  • Resolved Lab Lover

    (@peterscaffidi)


    I have thousands of the below entries in my PHP error log:

    “Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden”

    When I disable link builder, the errors cease. The errors started a couple of weeks ago.

    Amazon, please respond with detailed instructions how to resolve this issue.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same here.

    same here since 2.1.2018

    btw, the sucker seems to eat 259 milliseconds per request on average, because of this error (automatically measured via 200 tests with wp profile hook script).

    Lab Lover

    (@peterscaffidi)

    lucrus, I do not understand the significance of your 259ms statement.

    After investigation, I found Maxmind is using a security service from Cloudfare to protect its website from online attacks. Accessing to downloads without cookies seems to be the cause to be blocked and obtain a 403 HTTP status (Forbidden).

    If you update the database manually, you must update the aalb_geolite_db_last_updated_time and aalb_geolite_db_expiration_time options to get rid off new attempts to download until the defined date and avoid new errors logging.

    Example with wp-cli to stop error until Feb, 28th:
    wp option update aalb_geolite_db_expiration_time 1519772400

    I updated the aalb_geolite_db_expiration_time to 1519772400, but after a few seconds the value updates itself back to 0. Any idea what I´m doing wrong or how I can fix this?

    The Amazon Affiliate Links still don´t show up on my page.

    Same here. Please fix.

    @benn22, I updated also aalb_geolite_db_last_updated_time to 1515366000 (01/08/2018 00:00:00) after downloading and decompressing database to wp-content/uploads/amazon-associates-link-builder/. When the plugin estimates the database must be updated, it resets all two values to zero.

    cd /mypath/public_html/wp-content/uploads/amazon-associates-link-builder/
    wget http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz
    mv GeoLite2-Country.mmdb GeoLite2-Country.mmdb.bak
    gzip -d  GeoLite2-Country.mmdb.gz
    wp option update alb_geolite_db_last_updated_time 1515366000
    wp option update aalb_geolite_db_expiration_time 1519772400

    Of course, change mypath by yours.

    Let us know if this also works for you.

    • This reply was modified 1 year, 11 months ago by ABCdatos.
    • This reply was modified 1 year, 11 months ago by ABCdatos.

    Hi ABCdatos,

    thanks a lot for your help. The solution you posted works. After I uploaded the file the values now don´t get reset to 0 and I don´t get any mxmind_db errors anymore.

    The actual issue that I was hoping this fix would solve still presits. On my website dressurpferde-ausbildung.de the widgets from the Amazon Link Builder don´t show up anymore. I checked the logfile and found the maxmind_db errors next to some erros that I´m sending to many requests to the API (You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see <a href=http://docs.aws.amazon.com/AWSECommerceService/latest/DG/TroubleshootingApplications.html#efficiency-guidelines). Now the maxmind_db errors are gone, but I still have the issue of too many API requests. Any idea how I can debug the API request issue to find out why my website is sending so many requests? I implemented on some pages the widget generation code for Amazon links 2 – 4 times, but there is only little traffic on the page, so I can not imagine why I would send so many API requests.

    Error Log:
    (One can see the maxmind_db errors stop after the fix at 21:12, but the API request errors still exist.)

    [09-Jan-2018 21:03:41 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:03:46 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:04:33 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:06:33 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:08:33 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:10:34 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:12:34 UTC] Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden
    [09-Jan-2018 21:17:43 UTC] <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.</h4>
    [09-Jan-2018 21:17:43 UTC] <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.</h4>
    [09-Jan-2018 21:17:43 UTC] <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.</h4>
    [09-Jan-2018 21:18:01 UTC] <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.</h4>
    [09-Jan-2018 21:22:32 UTC] <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.</h4>

    This another log entry isn’t related to the maxmind database processing.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear Users,

    We fixed the issue in v1.5.3 of plugin released yesterday. Please update to the same and let us know if this problem got fixed for you.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error in maxmind_db_manager:get_db:::WP_ERROR: Forbidden’ is closed to new replies.