Support » Fixing WordPress » error in importing XML file

  • My blog has 700 posts and 4500 comments, when i try to export a XML FILE, it creates one XML file of 12 MB.

    but when i try to import it on my own domain it stops procssing after sometime. by double clicking that file, i saw following message in that :

    The XML page cannot be displayed

    “Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.”Reference to undefined entity ‘raquo’. Error processing resource ‘file:///C:/Documents and Settings/b/Desktop/wordpress.200…” error in line no 822.

    please help me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I’m having a similar issue. My original standalone WP install (1.2.2) was experimental but it seemed to work so I would just upgrade to each new version as it came out. I started having some miscellaneous problems lately and poked around and realized that the PHP was cluttered and the DB was a mess.

    I backed up the SQL and existing WP2.0.5 installation, reorganized the categories and posts the way I wanted them to be in the clean install, then used the Technosailor plug to export posts & comments to a 3MB XML file. Since the SQL backup dump is 2.9MB, I presumed the contents more or less matched, so I moved on to the next step.

    I deleted the existing WP install and DB, created a new DB and uploaded a clean installation of WP2.0.5. For all intents and purposes, it’s a completely new “out of the box” WP installation. There’s no legacy HTML or remnants of WP1.x code, no hacks, etc. I’ve uploaded all my plugins but none of them are activated.

    I went into the new config, set up my post categories to match the reorganized changes and then tried to upload the exported XML file. The importer mentions a WXR file, but the exporter gave me a file with an XML extension. When I try to import it anyway, it looks like it’s doing something for a minute or two, the status bar says “sending request,” then it just goes to a white page with the admin header at the top and the “Import WordPress” title in the body…and nothing else. I go to “Manage” to see if it did anything, and there’s nothing but Post #1.

    I tried changing the file extension to WXR to see if that made any difference, and I get the same results. Opening the file in Firefox 2.0 displays about 5 or 6 old posts followed by this:

    The XML page cannot be displayed
    Cannot view XML input using XSL style sheet.
    Please correct the error and then click the
    Refresh button, or try again later.
    A string literal was expected, but no opening quote character was found.
    Error processing resource 'file:///C:/TRANSFER/wor...

    It’s cut off like that in the display, but the path is to the XML file. If there’s an error on line number X, I can’t see what X is. When I open the file in Notepad, the entire content of my blog is there in order, right up to the very last comment posted before The Great Site Wipe.

    How do I use this file to restore my posts?

    Since I scrupulously backed up everything, I suppose I could reload the site as it was, but that defeats the entire purpose.

    For reference: I also posted a question on the plugin author’s site:

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘error in importing XML file’ is closed to new replies.