• Resolved Henry Peters

    (@henry-peters)


    Hi,

    I use the plugin on the linked page. In all browsers this works only in IE i get an error. Can you help me with this problem?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Jules Colle

    (@jules-colle)

    After a quick look I noticed your checkbox values says:

    Ik ben geen klant van Delphy. Ik ga akkoord met de kosten van € 35,- excl. BTW

    while your condition specifies:

    Ik ben geen klant van Delphy. Ik ga akkoord met de kosten van € 35,-

    Both should be equal

    Thread Starter Henry Peters

    (@henry-peters)

    I have changed this now but still ik get an error. This is what the console says:
    SCRIPT65535: Het argument is niet optioneel
    scripts.js, regel 286 teken 9

    Plugin Author Jules Colle

    (@jules-colle)

    Could you check if it’s fixed in version 1.7.1 ?

    Thread Starter Henry Peters

    (@henry-peters)

    Now in Firefox and Chrome the group only show and not hiding anymore. In the console: Uncaught ReferenceError: $inputs is not defined

    In IE show and hide are not working. In the console:
    Invalid site key or not loaded in api.js: xxxxxxxx recaptcha nl.js. But the key for recaptcha is the right one. It works in other form without conditional fields.

    Thread Starter Henry Peters

    (@henry-peters)

    fyi: i took the page from the live site and made a test page, https://delphy.nl/test-conditional/

    Plugin Author Jules Colle

    (@jules-colle)

    Could you check version 1.7.2?

    Thread Starter Henry Peters

    (@henry-peters)

    I installed 1.7.3. In Firefox and chrome everything ok but in IE: SCRIPT5007: Kan de eigenschap contains van een niet-gedefinieerde verwijzing of een verwijzing naar een lege waarde niet ophalen

    Thread Starter Henry Peters

    (@henry-peters)

    I looks like there is a conflict between reCAPTCHA and conditional fields. Forms without conditional-fields (but with the plugin active) could also not be sended in IE10-IE11. When i disabled the plugin they could be send.

    • This reply was modified 2 years, 7 months ago by Henry Peters.
    Plugin Author Jules Colle

    (@jules-colle)

    are you using the default reCAPTCHA provided by CF7?

    Thread Starter Henry Peters

    (@henry-peters)

    yes.

    Plugin Author Jules Colle

    (@jules-colle)

    I just installed recaptcha on my own site to test this, but seems to be working fine in IE..

    Could you try and set up this form on your site to see if it works? https://conditional-fields-cf7.bdwm.be/simple-form/

    Plugin Author Jules Colle

    (@jules-colle)

    I just tested on another website. And there I had a problem as well, but it turned out to be a problem with caching. I’m not sure if you are using a caching plugin, but if you do make sure to clear all caches before testing in IE11.

    Thread Starter Henry Peters

    (@henry-peters)

    Yes i cleared all caches. In IE11 it works now, in IE10 it is not working.

    Plugin Author Jules Colle

    (@jules-colle)

    I’m not sure if I’m going to support IE10. I’ll see if the changes I need to make aren’t too many and if they won’t slow down the code execution in modern browsers.

    Thread Starter Henry Peters

    (@henry-peters)

    I fully understand if your not support IE10. I’m glad it works now in IE11. THNX for your support!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Error in IE’ is closed to new replies.