WordPress.org

Support

Support » How-To and Troubleshooting » Error in deleting (posts, images, categories)

Error in deleting (posts, images, categories)

  • garbokaas
    Member

    @garbokaas

    Hi, I have recently upgraded to WP2.5. Almost everything works fine but I get an error when I try to delete a post or an image or an category through the corresponding manage tabs.

    Any ideas on this? I already tried re-uploading the WP files but that didn’t help.

    Thanx in advance!

Viewing 15 replies - 1 through 15 (of 33 total)
  • I’ve been getting that message too; I can’t delete anything from the “manage posts” page.

    A workaround is to edit the post (ie the “write post” page), then click the “delete post” button – this works but isn’t nearly as convenient.

    Anyone found a solution to this problem?

    Yemoonyah
    Member

    @yemoonyah

    I have a very similar problem, every time I try to delete a post or page I get error messages. I posted about this before (here)

    garbokaas
    Member

    @garbokaas

    Still haven’t found a solution fot this problem.

    It looks like not many people have this same problem otherwise we would have found many more posts on this subject. So this makes me suspect it has to do with an installation error. I think I will try to re-install my wordpress software.

    Yemoonyah
    Member

    @yemoonyah

    I tried that…didn’t help (but at least my uploader and gallery finally work)…groetjes uit Berlijn!

    Crap, I can’t delete pages and posts too from manage page. Though the workaround proposed by bork works for me.

    magicwand
    Member

    @magicwand

    Same problem here … I’ve even got some empty draft posts that I can’t delete

    I thought 2.5.1 might have fixed this but it’s still happening.

    dariusofthedark
    Member

    @dariusofthedark

    I’m having the same problem…it would be great to actually be able to delete more than one post at a time.

    If you attempt to delete more than one post at a time, the delete processing seems to run completely for each post, and that includes triggering any plugins that react to site changes, such as the Sitemaps plugin or similar.

    I can delete posts one at a time, but it takes LONG time for it to run, and comes very close to timing out PHP to do it.

    It doesn’t make any sense because I can go into PHPMyAdmin and delete a post in about 1/10 of a second.

    I have similar problem with this difference wordpress shows error but it deletes post. I’ve looked inside of the wp scripts but have no idea why it shows error.

    Sorry about my english

    I found a solution for this problem.

    In wp-admin/edit-page.php, wp-admin/edit.php. It have code below:

    :::line 160

    $sendback = wp_get_referer();
    
    	if (strpos($sendback, 'post.php') !== false) $sendback = get_option('siteurl') .'/wp-admin/post-new.php';
    	elseif (strpos($sendback, 'attachments.php') !== false) $sendback = get_option('siteurl') .'/wp-admin/attachments.php';
    	$sendback = preg_replace('|[^a-z0-9-~+_.?#=&;,/:]|i', '', $sendback);
    	wp_redirect($sendback);
    	exit();

    function wp_get_referer() return false if $_REQUEST[‘_wp_http_referer’] or $_SERVER[‘HTTP_REFERER’] same $_SERVER[‘REQUEST_URI’]. Then, wp_redirect return false on $sendback as is empty. No page to redirect, and white page return to browser.

    My solution:

    Add code below line $sendback = wp_get_referer();

    $sendback = wp_get_referer();
    	// fix error after delete
    	// return false if same RequestUri
    	if ($sendback === false) $sendback = $_SERVER['REQUEST_URI'];

    Thanks.

    magicwand
    Member

    @magicwand

    Nope, that didn’t work either.

    This is a massively irritating problem and frankly a major issue with the functionality and usability of the admin interface. Has it not been raised in TRAC? No developer looking at it?

    We are using WPMU which already has a number of glitches we still haven’t found answers for, but such a problem in the admin interface is affecting all our blog users too.

    Im having the same problem too .. pretty anoying. Has anyone found a solution for this issue yet??

    bump

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Error in deleting (posts, images, categories)’ is closed to new replies.