Support » Fixing WordPress » Error in b2mail.php

  • Fatal error: Call to undefined function: dbconnect() in /home/noahgo2/public_html/wordpress/b2mail.php on line 14
    and when I pull up the b2mail.php file the code reads:
    # pop3-2-b2 mail to blog
    # v0.3 20020716
    etc. etc….
    Any ideas? Is there a reference missing there? The rest of WordPress seems to be humming along just fine. Thanks all!

Viewing 4 replies - 1 through 4 (of 4 total)
  • AH-HAH! Further info:
    I have a simple cron-job running hourly calling the b2mail.php file in public_html/wordpress/.
    When the cron runs it returns me via E-mail the following message:
    /bin/sh: line 1: /home/noahgo2/public_html/wordpress/b2mail.php: Permission denied
    I’ve tried chmod-ing the b2mail.php file to 777 and then opening b2mail.php in my browser window but was returned the same message as in my original post:
    Fatal error: Call to undefined function: dbconnect() in /home/noahgo2/public_html/wordpress/b2mail.php on line 14
    and now I’m REALLY stumped…

    Try upgrading to the latest beta. I’m seeing different code in that file when I look at the current version in CVS.

    Yeah, I just found an old post that explained things. I commented out the erring line and now I’ve discovered that my server’s not RFC1939… *sigh*. Thanks for looking into it.
    And with that… has anyone found a solution to the
    “Ooops POP3: premature NOOP OK, NOT an RFC 1939 Compliant server”
    issue? I downloaded the latest CVS beta file (last modified by Mike six weeks ago) and got the RFC message again.
    Thanks all.

    I found the RFC fix and it’s now all up and going (even the cron! Although I have to wget the http: path):
    {begin fix. I did this and it worked, it’s a one-character code mod}
    If you get that error you need to edit class.POP3.php
    find the line with the premature error in it (around line 110) and edit:
    if($this->RFC1939) {
    if(!$this->RFC1939) {
    {end fix}

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error in b2mail.php’ is closed to new replies.