WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Error in automatic upgrade to 3.5.1 – Windows

[Resolved] Error in automatic upgrade to 3.5.1 – Windows

  • I am experiencing an error when trying to upgrade from 3.5 to 3.5.1 on a Windows server. Here are the error messages:
    +++++++++++++++++++++++++++++++++++++++++++++++
    Downloading update from http://wordpress.org/wordpress-3.5.1-partial-0.zip…

    Unpacking the update…

    The package could not be installed.: PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘C:\WINDOWS\TEMP/wordpress-3.tmp’

    Installation Failed
    +++++++++++++++++++++++++++++++++++++++++++++++

    Note the wrong (for Windows) forward-facing ‘/’ before ‘wordpress-3.tmp’. Is this the cause of the problem? If so, please fix Woprdpress team! The problem also affects plugin upgrades.

    Many thanks, Anthony

Viewing 10 replies - 1 through 10 (of 10 total)
  • keesiemeijer
    Moderator

    @keesiemeijer

    Teflon
    Member

    @foxnwolf

    Hi, need assistance. Am getting this message (see below) when trying to upgrade to “Word-press 3.5.1.” I also get this message when I try and upgrade my Plugins (SI Capture) & (Fast Secure Contact Form)

    Error message below this line……. Thanx Mac

    Update WordPress

    Downloading update from http://wordpress.org/wordpress-3.5.1-partial-0.zip…

    Unpacking the update…

    The package could not be installed.: PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘C:\WINDOWS\TEMP/wordpress-3.tmp’

    Installation Failed

    Add the following to your wp-config.php. Remove it after updating to WordPress 3.5.1, says Codex (http://codex.wordpress.org/Version_3.5.1#Windows_Servers_Running_IIS), but I did not bother.

    define( ‘WP_TEMP_DIR’, ABSPATH . ‘wp-content/’ );

    I am hoping that the WP team sorts this error soon.

    Forgot say that adding:
    define( ‘WP_TEMP_DIR’, ABSPATH . ‘wp-content/’ );
    to your wp-config.php file sorts the problem for plugin upgrades as well.

    Teflon
    Member

    @foxnwolf

    Hi Anthony… appreciate the quick reply. Am updating some of my posts on Locknload via WordPress and also my Foxnwolf site via Dreamweaver.

    Whilst in Dreamweaver I opened “wp-config.php” file and scrolled to the bottom of the page and noticed a area were the file update could be placed.

    I am only techy to a limit as self taught so the hairs are currently standing up on the back of my neck.

    Could you advise where I should place the modified txt as there are two blocks of txt/php instructions that have the word “define” and I need to know which one and also do I just (add to the end)

    Thanx… Teflon aka Mac

    Teflon
    Member

    @foxnwolf

    Anthony

    Off for a Marlboro and Espresso break. Your reply will come via my cell phone… Thanx again… Mac

    keesiemeijer
    Moderator

    @keesiemeijer

    First Make a backup of the file. You don’t need to change anything that is already in your wp-config.php, just add it at the bottom.

    Don’t forget to remove the code when you’ve updated your site.

    Teflon
    Member

    @foxnwolf

    Hi K, many thanx for yours and Anthony assistance in this matter. Followed your instructions to the letter and it works. All updates and downloads done and dusted. And as you advised that extra line of txt was removed, then page refreshed again afterwards.

    To say thanx, you guys get a mention on my site at the bottom of the page on this link… “http://www.foxnwolf.com/locknload/”

    Finally, Does this mean I must add that line every time I have the same issues (as above)? Or, will “WordPress” incorporate a fix somewhere along the line?

    I dont know where your located but have a great day, the sun is going down here so I will raise a glass or two of a bottle of Jack. Again, many thanx its great to know that help is around when you need it…

    Teflon aka Mac…

    keesiemeijer
    Moderator

    @keesiemeijer

    Finally, Does this mean I must add that line every time I have the same issues (as above)

    No this was a bug in 3.5 that has been solved with 3.5.1
    http://core.trac.wordpress.org/ticket/22900

    I’m glad you’ve got it resolved 🙂

    Teflon
    Member

    @foxnwolf

    Thanx K`

    Issue totally resolved

    Mac…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Error in automatic upgrade to 3.5.1 – Windows’ is closed to new replies.