[resolved] Error in admin screens - Facebook unable to save file/directory (4 posts)

  1. Tacoking
    Posted 3 years ago #

    Just updated the Facebook plugin, and I'm now getting errors at the top and bottom of all my admin pages. Here are the ones at the top:

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/50/3946950/tmp/sess_c0b2b4bji2qci5chd81keb7r67, O_RDWR) failed: No such file or directory (2) in /home/content/50/3946950/html/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 51

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/50/3946950/html/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:51) in /home/content/50/3946950/html/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 51

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/50/3946950/html/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:51) in /home/content/50/3946950/html/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 51

    Tried a full reinstall of the plugin, tried resetting all the options, and even reset the AppSecret for this app. Nothing helped. I didn't see this exact error in the ones being reported, so any help is much appreciated.


  2. Niall Kennedy
    Plugin Author

    Posted 3 years ago #

    This is an error with the Facebook PHP SDK; not specific to the plugin. https://github.com/facebook/facebook-php-sdk/blob/master/src/facebook.php#L35

    Which web host or PHP config is throwing this error?

  3. Tacoking
    Posted 3 years ago #

    I'm on Dreamhost, but none of my other WP sites are having an issue. And I just checked again and don't see any other plugins on this site I'm not also running elsewhere.

    Any ideas are much appreciated.

  4. Tacoking
    Posted 3 years ago #

    This issue has been solved. This hosting was on GoDaddy, not Dreamhost like I said earlier. They apparently did not have a setting enabled for my hosting that allowed multiple sessions. So when this plugin tried to create the tmp directory, it failed.

    I am not clear why the previous version of the plugin didn't have this issue, but GoDaddy has now resolved it and things are working fine. Apparently this can impact other plugins, too, so if you see a plugin with a session_start error and open .../tmp/... failed, contact your hosting provider.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic