Support » Theme: Botiga » error in 404 page

  • Resolved burgerino

    (@burgerino)


    hello! I get this error in 404 page. What could be an issue?

    Warning: Attempt to read property “post_content” on null in /home/gigant/domains/pcgigant.lt/public_html/wp-content/plugins/athemes-blocks/classes/class-athemes-blocks-init.php on line 121

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi @burgerino,

    I am sorry for the trouble.

    We have been added this to our bugs tracker and the permanent fix for this will be available in upcoming plugin update.

    If you want to fix it by yourself from plugin’s file, try:

    1. Edit the athemes-blocks/classes/class-athemes-blocks-init.php file
    2. Find these lines:

    
    if( strpos( $post->post_content, 'parallax' ) !== FALSE ) {
        wp_enqueue_script( 'athemes-blocks-parallax' );
    }
    

    3. Add this code before that line

    
    if( null == $post ) {
      return;
    }
    

    So the code block will look like this:

    if( null == $post ) {
      return;
    }
    
    if( strpos( $post->post_content, 'parallax' ) !== FALSE ) {
        wp_enqueue_script( 'athemes-blocks-parallax' );
    }

    4. Update this code changes to your site.

    Regards,
    Kharis

    Thread Starter burgerino

    (@burgerino)

    Thanks for this! I was just wondering if your aThemes plugin is essential to run Botiga theme?

    Thank you for getting back @burgerino!

    I can confirm that aThemes Block plugin is essential for Botiga. Because it contains several special blocks to enhance he design purpose on particular parts shown in the theme demo. If you don’t want to use it, you’ll need to identify which content/block from the plugin not optimal for your need.

    Regards,
    Kharis

    Thread Starter burgerino

    (@burgerino)

    Hi! I was wondering if you’ve issued a permanent fix for this? Thanks

    Hi @burgerino,

    We released a new version from aThemes Blocks plugin that fixes the issue. Please try updating the plugin to the latest version from Admin Dashboard > Plugins

    We hope this helps!

    Kind Regards,

    Rodrigo.

    Thread Starter burgerino

    (@burgerino)

    Rodrigo, thanks a lot for this. You are guys great!

    Thread Starter burgerino

    (@burgerino)

    Rodrigo, I am not sure if it is related to the update but I noticed that after the update, it is impossible to turn on the slideshow in the product page.

    Hi @burgerino,

    Rodrigo, thanks a lot for this. You are guys great!

    You are welcome!

    Rodrigo, I am not sure if it is related to the update but I noticed that after the update, it is impossible to turn on the slideshow in the product page.

    No. It shouldn’t be related with the aThemes Blocks plugin update. I did some tests here and it’s working fine. Probably you are having some caching issue. Please try to clear all cache after save/publish the changes.

    We hope this helps!

    Kind Regards,

    Rodrigo.

    Thread Starter burgerino

    (@burgerino)

    Rodrigo, I tried to clear the cache and the problem still persist. I also tried it using mobile phone and other devices, the issue is there. It is possible that I was not clear. If you press on the magnifier (left top corner of the picture), the product picture does not appear in a full-screen. The zooming, while the cursor is on the picture, does work.

    Regards

    Thread Starter burgerino

    (@burgerino)

    Hi, I was wondering if you had a chance to take a look into this? Thanks

    Hi @burgerino,

    Sorry for the late reply here!

    It looks like the “Product Enquiry for WooCommerce” is the culprit of the issue. Please try following my instructions below:

    1. Install this plugin: TC Custom Javascript
    2. Go to Admin Dashboard > Appearance > Custom Javascript and add this code in the box: https://pastebin.com/raw/CGcRh8Hg

    We hope this helps!

    Kind Regards,

    Rodrigo.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.