Support » Fixing WordPress » Error Importing SQL Database – 404 File or directory not found

  • Hi everyone,
    I’ve recently moved my website to a new host and I made several backup files of my WordPress posts, comments, images etc from the old website and once I had set up WordPress on the new site I installed the same Theme and Plugins.

    Then within phpMyAdmin I attempted to import one of these SQL database files (they are approximately 38MB in size)

    I select the SQL file and leave all other settings to their default position, I then click the ‘Go’ button to start the import process, and everything looks as though its working and for five minutes I can see evidence that the import is progressing smoothly.

    Then every single time I’ve tried to do this I receive the following error message:

    The right hand side of the phpMyAdmin page changes to read:

    Server error
    404 – File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    I’ve spoken to my new host company about the error and they just point me to webpage explaining how to import SQL files into WordPress (which I’ve followd to the letter) and claim they do not support phpMyAdmin (eventhough they offer it as part of their hosting package).

    I receive this error message every time and I’m left scratching my head wondering what I might be doing wrong.

    If anyone can offer any advise at all, however small I really would be grateful. I’m far from an expert in phpMyAdmin or WordPress but as far as I can tell I’m doing everything that I should be doing to import an SQL file.

    Any help, pointers or suggestions would be very gratefulyl appreciated.

    Kind Regards,
    Wayne

Viewing 3 replies - 1 through 3 (of 3 total)
  • i think it is because the size of the file, you reach the max execution time and/or max input time and the file get deleted.

    if the file is not zipped (compressed), try to zip that and import again using phpmyadmin or you can use http://www.ozerov.de/bigdump/

    hope helps

    It is definitely related to the file size. In this case I think you should advise your hosting provider what you are trying to do, i.e. that you are trying to restore a BIG database. Maybe you can send them the file and they can sort it out for you.

    Thanks very much for taking the time to reply to my post, I wasn’t even aware that I could upload a zip file, I just assumed it had to be an SQL file but after zipping it up I got the size down to below 5MB and it uploaded without any issues at all, so I now know it was the file size causing the error message.

    However that hasn’t completely resolved the issue as I seem to be experiencing something else now.

    Once the zip file has been imported if I then navigate to my website, instead of seeing my wordpress blog all I see is another error message:

    Not Found
    The requested document was not found on this server

    When I check the database in phpMyAdmin after the import I can see loads and loads of additional tables and records that were not there before the import, so that would indicate the import has worked, the only noticable difference I can see is prior to the import, the basic wordpress tables were listed with their relevant names, after the import I see every table prefixed with wp_ and the original tables seem to have vanished, or perhaps been overwritten with the imported tables … but I’m not sure if that has any relevence on this issue, I’m really clutching at straws!

    If anyone can shed some light on this I would again be very grateful for your input.

    Kind regards,
    Wayne

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error Importing SQL Database – 404 File or directory not found’ is closed to new replies.