Support » Plugin: Events Manager » error: Illegal offset type in isset or empty

  • Resolved GregorH

    (@gregorh)


    Hello,
    I noticed today that when EM is activated on my site template and doing a search for businesses in my template (which is a business directory), I get this error when submitting the search button:

    Warning: Illegal offset type in isset or empty in /home/xxxxxxxxx/public_html/wp-includes/post.php on line 1097

    This happens only when EM is activated.
    What can this be?

    I am using EM latest version 5.3.6.1

    http://wordpress.org/extend/plugins/events-manager/

Viewing 11 replies - 1 through 11 (of 11 total)
  • hi,

    didn’t get this warning message; can I know what is your WP version? and/or try to disable your php display_errors since it’s only a warning and not a fatal error. also, do you have a sample link?

    Hello,

    thanks for your reply!

    1. Latest version of WP (3.5.1)

    2. it is not just a warning! also the search result is influenced by this error, usually I should get a valid search result searching for example for “Golf” but I get a “NOTHING FOUND” in the results, while the map on top shows the correct result.

    3. you can see it here: lanzaguide.com
    when you put a word in the “search keyword…” field which usually searches businesses in the directory, and than hit the green search button, you get this error.

    When I disable EM the error does not show and the results show correctly.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    what about if you try to prevent EM from including its items in search results?

    e.g. in Events > Settings > Pages > Events(and Locations) List/Archives

    Hi Marcus,

    If you mean: “include in WordPress Searches?” it was set to NO! But I changed it now to YES and this did the trick! Seams to work now!!!!

    Thanks a lot for pointing me in the right direction !!!!

    For what it’s worth, switching this setting to YES fixed the problem for me as well. From what you said, Marcus, that’s the opposite of what you expected. Something strange going on here?

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    the issue may be that your theme is doing something special with searches which look for specific post types. hard to say since each theme can do something unique.

    for me with the default theme, I get no php errors regardless of that setting.

    We’re using Genesis. I don’t know if it makes any changes to the way searches are performed.

    devEdge

    (@devedge)

    Also ran into this issue. Changing the search setting as described in this post fixed it.

    I am running Genesis as well (version 1.9.2). WordPress 3.5.1. Events Manager version 5.4.2.

    My custom search form code:

    <form method="get" class="searchform search-form" action="<?php echo home_url( ); ?>/" >
    	<?php /* This limits the search to custom post type of member-profile only */ ?>
    	<input type="hidden" name="post_type" value="member-profile" />
    
    	<input type="text" value="<?php echo esc_attr( $search_text ); ?>" name="s" class="s search-input"<?php echo $onfocus . $onblur; ?> />
    	<input type="submit" class="searchsubmit search-submit" value="<?php echo esc_attr( $button_text ); ?>" />
    </form>

    The variables used in the code are irrelevant for recreating the issue.

    Thank you Marcus for this awesome plugin. 🙂

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    thx for sharing!

    This is not THEME related – I am building custom theme and I get same error. This is fixed when include in WordPress Searches? is set to yes… odd 🙂

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    given the snippet above, i think the clue here is post_type being sent in custom forms.

    however, I can’t even reproduce this on the parent genesis theme. that said, we may have fixed this at some point given the age of this thread.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘error: Illegal offset type in isset or empty’ is closed to new replies.