WordPress.org

Support

Support » How-To and Troubleshooting » Error HTTP 404 Not Found error after Permalink change

Error HTTP 404 Not Found error after Permalink change

  • I built a test server running RHEL6 with Apache installed. WordPress installed without an error. With the default Permalink settings I am able to access all of the web pages generated by WP. When I change Permalinks to Post Name then Save changed I see that WP is modifying my .htaccess file but I get an Error 404 when trying to access any of my posts. mod_rewrite is enabled in Apache. I have tried different remedies specified in the WP Forums but none of them has fixed the problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Solved!

    Changed AllowOverride from None to All in httpd.conf.

    Iā€™m having the same problem!:( but I found the solution . my server :Centos 5.7 ,apache 2.4. permalink structure used rewrite_module in apache.rewrite rules into .htaccess . but it didn’t work for me. Check httpd.conf , “AllowOverride None” It defaults to None,change to ALL.Then that’s ok! šŸ™‚

    very Sorry about my bad english!!!

    Hi, I’ve been figuring this out for a few hours now. This answer is the only one that helped me so far! šŸ˜€

    addition: don’t forget to restart httpd after making changes to httpd.conf for the changes to be loaded.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error HTTP 404 Not Found error after Permalink change’ is closed to new replies.
Skip to toolbar