Support » Plugin: Cloudflare » Error Hooks.php on line 133

  • …/wp-content/plugins/cloudflare/src/WordPress/Hooks.php on line 133
    Not possibly not compatible with that version of PHP7.2.
    I hope the team will fix this as soon as possible.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Seeing this as well but ONLY when Automatic Cache Managemnent is enabled. If you disable it you don’t get these errors

    Warning: count(): Parameter must be an array or an object that implements Countable in /wp-content/plugins/cloudflare/src/WordPress/Hooks.php on line 133

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/cloudflare/src/WordPress/Hooks.php:133) in /wp-admin/post.php on line 198

    I am also using PHP 7.2 as that is what is recommended by WooCommerce but if you disable Auto Cache Management this goes away as a work around.

    On /wp-content/plugins/cloudflare/src/WordPress/Hooks.php:133, change

    if (count($wpDomain) <= 0) {

    to

    if (strlen($wpDomain) <= 0) {

    • This reply was modified 2 years, 5 months ago by KenLewis.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error Hooks.php on line 133’ is closed to new replies.