Support » Plugin: Portable phpMyAdmin » Error: Headers already sent

Viewing 14 replies - 1 through 14 (of 14 total)
  • Just checking if there has been an official fix for this or if someone has unofficial fix until the plugin author fixes it.

    Plugin Author Ciprian

    (@butterflymedia)

    @marcelo, I have removed the HTTPS check, see version 1.4.

    I’d love some more feedback.

    Hi! the errors regarding headers already sent and isHTTPS have gone, but there is a new one:

    Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time in /home/giprrhh/public_html/wp-content/plugins/portable-phpmyadmin/pma/libraries/session.inc.php on line 54

    The line 54 does the following:
    ini_set('session.use_trans_sid', true);

    I have WP 3.5.1 under PHP 5.4.13.
    I tried disabling that command and then I obtain this bigger error:

    Fatal error: main(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "PMA_Config" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/giprrhh/public_html/wp-content/plugins/portable-phpmyadmin/pma/libraries/common.lib.php on line 2852

    The problem with line 54 is that you MUST define the variables with ini_set BEFORE stating a session_start() command.

    Plugin Author Ciprian

    (@butterflymedia)

    It must be a server issue as I don’t have that error on 3 different servers. I will check it and fix it ASAP.

    Thank you for your feedback.

    oh wait, excuse me, what version of phpmyadmin are you using?

    Plugin Author Ciprian

    (@butterflymedia)

    The latest one 🙂 1.4.1

    nope, I ask about the PMA version which is shipped within your plugin

    Plugin Author Ciprian

    (@butterflymedia)

    It’s written inside the Help page. Don’t remember now, I’ll update the plugin tomorrow and reply to all open threads here.

    I see, your plugin have phpMyAdmin 2.11.11.3. That’s almost 5 years old!
    https://github.com/phpmyadmin/history/blob/master/ChangeLogs/ChangeLog-2008

    Actual phpMyAdmin stable version is 3.5.8.1 !!! Did you need to modify anything in phpmyadmin other than mysql database, login and password in order to make it work?

    I recommend you to update your phpmyadmin version before continue updating this plugin, since there are TOOOOO MANY improvements in phpmyadmin to add here.

    Plugin Author Ciprian

    (@butterflymedia)

    I do not agree. The latest version is bloated and has lots of scripts and AJAX behaviour. My phpMyAdmin is based on 2.11.11.3, but has lots of future updates, according to later fixes, forum discussions and personal programming.

    I don’t see the problem with Ajax, if you load the PMA in an iframe, it’s self contained 🙂
    Does this work without problems with PHP 5.4 and MySQL 5.5?

    Plugin Author Ciprian

    (@butterflymedia)

    I know it’s self-contained, but it’s big. Version 2.x did its job perfectly, and, usually, developers look for light software, not bloated, to help them manipulate the database.

    It works OK with PHP 5.4, I haven’t tested it with MySQL 5.5.

    ok, be sure this work well with MySQL 5.5, it’s the version almost all web hosting providers must have running before this year end.

    I have same problem version 1.4.1.

    Apache 2.4.2
    PHP 5.2.14
    MySQL 5.5.27
    WordPress 3.5.1

    I get 1 warning and 2 errors.

    PHP Warning:  ini_set() [<a href='function.ini-set'>function.ini-set</a>]: A session is active. You cannot change the session module's ini settings at this time in C:\Apache24\htdocs\mysite\wp-content\plugins\portable-phpmyadmin\pma\libraries\session.inc.php on line 54
    
    PHP Fatal error:  main() [<a href='function.main'>function.main</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "PMA_Config" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition  in C:\Apache24\htdocs\mysite\wp-content\plugins\portable-phpmyadmin\pma\libraries\common.lib.php on line 2852
    
    PHP Fatal error:  Call to a member function get() on a non-object in C:\Apache24\htdocs\mysite\wp-includes\cache.php on line 113

    I tried session.auto_start turned On.
    but still get 1 error

    PHP Fatal error:  Call to a member function get() on a non-object in C:\Apache24\htdocs\mysite\wp-includes\cache.php on line 113

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error: Headers already sent’ is closed to new replies.