Support » Plugins and Hacks » WPPizza » [Resolved] Error has me stumped

[Resolved] Error has me stumped

  • Hey Guys,

    Just want to say, great plugin everything was easy to work and looks great.

    However, i seem to have run into a little problem. everything worked fine until i tested the final stage of placing an order. when i got to that point and hit send i get this message:

    Only variables should be passed by reference

    been looking round the forums but it seems to be a code specific problem and im not sure how to fix it. any ideas?

    strangest thing is that i loaded it up onto a another site i was working on (differnt domain and hosting) and it worked fine… hoping its an easy fix.

    look forward to hearing from you soon



Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author ollybach



    do you have a link i can look at ?
    also, can you turn on (if you havent done already) debug
    and let me know the exact output ?


    Plugin Author ollybach


    haven’t heard from you so
    i guess that’s sorted then !?

    marked as resolved

    Hi Olly,

    Just got your mail, sorry I replied via gmail which was forwarded to me, and it must not have sent it to you. heres what i sent:

    Rajan Zaveri <rajan.zaveri@gmail.com>
    Apr 8 (2 days ago)


    the website is http://imperfecto.in

    ok so im pretty green, dont know how to run debug or what you mean by exact output. I’ve attached a screen shot of the error that comes up.

    hope this helps, thanks for getting back to me so quick


    not sure if youll be able to see this but its a url of the screen grab:

    sorry for the misunderstanding


    Plugin Author ollybach



    just tested it on your site.
    i’ll download your theme (for starters) and see what happens on my box..bear with me for a bit

    no worries, want me to send you the theme?

    Plugin Author ollybach


    no. (unless you have nothing better to do )
    anyway, tried it on my box with your theme and it works just fine.

    you can do me a favour though (which might help)

    in your wp-config.php

    define(‘WP_DEBUG’, false);


    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    this will generate a debug.log file in your wp-content folder
    make an order and when you get the error message send me that debug.log file (send it to dev[at]wp-pizza.com)

    furthermore, maybe you can put a file in the root of your site (named info.php for example)

    with the following code:


    so i can see what’s running there (you can also rename that file. just let me know what its called by email. not really necessary that the whole world knows your setup

    does that make sense ?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Error has me stumped’ is closed to new replies.