Support » Plugin: WP Security Audit Log » Error: function is_trial() on freemius

  • Resolved samuelbernardo

    (@samuelbernardo)


    With latest 2 updates using multisite configuration with wordpress 4.9.4 the following error happens:
    [error] 28387#28387: *831149 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to a member function is_trial() on boolean in xxx/wp-content/plugins/wp-security-audit-log/sdk/freemius/includes/class-freemius.php on line 9006” while reading response header from upstream, client: xxx, server: xxx, request: “GET /wp-admin/network/update-core.php?action=do-plugin-upgrade HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “xxx”

    To temporary solve the situation I just edited plugin code and change the following code line (temporary solution to bypass the error):

    – return $this->_site->is_trial();
    + if ( ! is_object( $this->_site ) )
    + return true;
    + else
    + return $this->_site->is_trial();

    It seems that with recent update of FS_SITE there is no object for _site since it appears to be false. But when testing on wordpress single site mode it works as expected.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Hello @samuelbernardo

    Thank you for using our plugin and sorry you are encountering such error. We cannot replicate the error ourselves so can you please answer the below questions so we can troubleshoot and solve this issue?

    1) When is such error happening, during activation or when you do something specific?

    2) Is this error a “show stopper” or you can still use the website / plugin?

    Looking forward to hearing from you.

    1) Error is happening after activation when accessing dashboard of any site of multisite wordpress

    2) This error 500 prevent the administration of sites from wp-admin, but viewing the site contents work normally. This is related to the activation of freemius and sending feedback. My proposed patch don’t allow that activation, but keeps working wp-security-audit-log plugin as before.

    Feel free to contact me if you require further details.

    Thanks

    @samuelbernardo my name is Vova and I’m from the Freemius team. The error mentioned is thrown from our SDK, hence, our responsibility. Could you please install and activate our troubleshooting plugin, then download a data dump of the stored Freemius data, and send it to us for an investigation to [support AT freemius DOT com]. Thanks!

    samuelbernardo

    (@samuelbernardo)

    I run troubleshooting plugin and download data dump of stored freemius data.
    I’ll send the email now.

    ksaylor11

    (@ksaylor11)

    I’m still experiencing this issue in 3.1.4. Will there be a patch to this issue soon?

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Hello @ksaylor11

    Can you please help @svovaf with troubleshooting this, by sending him the required data (as explained here)?

    Thanks a lot for your cooperation.

    @ksaylor11 please contact me directly via [support AT freemius DOT com] while referring this issue.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Hello @ksaylor11,

    @samuelbernardo had got back to us and confirmed that after running the cleanup script given by Vova and installing the latest update of the plugin his issues were solved.

    So can you please contact Vova and advise us?

    Thank you.

    ksaylor11

    (@ksaylor11)

    @wpwhitesecurity and @svovaf

    I just updated wp-security-audit-log to Version 3.1.5 on a site today and I’m not noticing any issues. I’ll try later today with another site.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Glad it is sorted @ksaylor11.

    Should you encounter any other issues do not hesitate to get in touch.

    Thank you for using our plugin.

    Just a heads up. I finally got back around to one of the sites I manage and when you reinstall wp-security-audit-log and network activate it craps out with the vague error:

    Error thrown
    Call to member function is_trial() on boolean

    If you deactivate and then go to the root site plugins and activate it, it appears to work fine. Something about the network activate?

    Plugin Contributor robertabela

    (@robert681)

    Hello @ksaylor11,

    A few weeks ago you reported that all is running well for you.

    So what happened here? Did you try to install the latest version (3.1.7) on a new site and you experienced this problem?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error: function is_trial() on freemius’ is closed to new replies.