Support » Plugin: Site Reviews » Error from last updates

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    I can see that you are using the “Page Builder by SiteOrigin” plugin.

    Since Site Reviews v3.0 has been rebuilt from the ground up, the underlying widget name that the “Page Builder” sees has likely changed. To fix this, you will need to remove the old widgets and re-add them.

    I am looking into the PHP warnings now and should have a fix released within the hour. Would you try going to the “Site Reviews > Tools” page and clicking the “Recalculate counts” button?

    • This reply was modified 1 year, 1 month ago by Gemini Labs.

    ok thank you. I have clicked on this button now, but the error is not fixed.

    Plugin Author Gemini Labs

    (@geminilabs)

    Thanks. Expect a fix in the next hour or so.

    I hope this will not happen again. Because if need to delete and add again widgets for each update… I will not be able to change the widget for 1000 posts I will stop use this plugin if this happen again!

    Plugin Author Gemini Labs

    (@geminilabs)

    v3.0 was rewritten to fix the issues from v2.0 that would cause your website to slow down when you started to get thousands and thousands of reviews, and to allow for new features that were not possible in v2.0 because of the way it was built. It’s essentially a new plugin.

    Since it’s a major (version x.0.0) version update, even though much care was put into testing all possible configurations, it’s realistic that there will be problems that crop up as it is impossible to anticipate everyone’s server/website/plugin configuration.

    All other incremental minor (version 0.x.0) and patch (version 0.0.x) updates should add features and fix issues, but should not introduce any breaking changes.

    • This reply was modified 1 year, 1 month ago by Gemini Labs.

    Yet one problem When add in one page last 20 Reviews for all sites no have link and title for what is this member voted. Just is writen reveiw and member name……for what is this review no one know the link missing and post title….very bad update! Please fix this also.

    Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    Both the shortcodes and widgets allow you to hide review fields that you do not want shown. For example: [site_reviews hide=title] will hide the title field of the reviews.

    Have you used any of the old v2 filter hooks in your functions.php file to customize the way your reviews are displayed? v3.0 now uses plugin templates instead of filter hooks.

    If you like, you can create a user with editor permissions and send the credentials to site-reviews[at]geminilabs[dot]io and I will look at your site to help with the upgrade process.

    Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    I just re-read your message above about changing the widget for 1000 posts.

    Are you manually adding a widget on each of your posts (I’m assuming you have thousands of posts)?

    1. If you are, I would be happy to help you modify your theme so that this is done in your template (using <?php echo do_shortcode( '[site_reviews]' ); ?> etc.) instead which would make your site easier to manage and maintain.

    2. Alternatively, the Page Builder plugin also allows you to create a pre-built blocks which can be re-used on every page. This allows you to change it only once and it will be changed everywhere.

    3. Site Reviews also allows you to use “post_id” in the assign_to and assigned_to options. So if you require that the reviews are assigned to each respective post, you can do this:

    [site_reviews assigned_to=post_id]

    instead of this:

    [site_reviews assigned_to=1322]

    • This reply was modified 1 year, 1 month ago by Gemini Labs.
    • This reply was modified 1 year, 1 month ago by Gemini Labs.
    Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    I have just pushed v3.0.2 which should fix the PHP warnings you experienced, and also provide some additional logging in the Site Reviews console (on the Tools page) if needed.

    Please update when you see it available and let me know how it goes.

    If after updating you are seeing non-update-related entries in the Console (Site Reviews > Tools > Console), please download both the Console and the System Info and send both files to site-reviews[at]geminilabs[dot]io

    Thanks

    • This reply was modified 1 year, 1 month ago by Gemini Labs.
    • This reply was modified 1 year, 1 month ago by Gemini Labs.

    I changed all widget for all posts…..2 days work! And now I notice that have bugs….for example: in one post I added last reviews for this post and added post ID also Sumary of reviews with post ID. but in the post not show last reviews. In Sumary of reviews is writen (4.5 out of 5 stars (based on 2 reviews) but bellow i last reviews not show this 2 reviews….. Please fix this….

    Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    It sounds like you are experiencing problems due to your caching plugin. Please disable the LiteSpeed Cache plugin and clear the plugin cache on your site. Once you have done this, please test again.

    Version 2 would calculate the review summary on every page load. This resulted in horrible performance when there were thousands of reviews. Version 3 now stores this value and recalculates it whenever a review is created, updated, and deleted.

    If you are experiencing problems that reviews are not showing up after they have been submitted, or that the summary is not updating properly, this is 99% due to one of the following reasons:

    1. You are possibly using incorrect widget/shortcode settings, for example, a common mistake that users have made is mixing up the “assign_to” and “assigned_to” options. Sometimes users have also used the wrong post_ID in the assigned_to option. I always recommend to use the shortcode like this: [site_reviews assigned_to=post_id] instead of this: [site_reviews assigned_to=2087].

    2. You are possibly using a caching plugin which is caching the page and/or database queries/objects, and when reviews are being submitted the cache is not being rebuilt so it is showing the outdated cached page.

    I’m sorry that you had to spend 2 days adjusting your website to fit the new v3.0 update. It was necessary to change Site Reviews in order to continue development and add new features. Even though I’ve tried to ensure compatibility with every plugin (in your case it was Page Builder by SiteOrigin), I can’t always guarantee that I will take into account every scenario. But I will do whatever I can to help when these problems are found.

    • This reply was modified 1 year, 1 month ago by Gemini Labs.
    • This reply was modified 1 year, 1 month ago by Gemini Labs.
    • This reply was modified 1 year, 1 month ago by Gemini Labs.

    Thank you. I dsiabled this plugin and clean browser cache but yet not show last votes. I make new vote and show it but old 2 votes missing. Show that have 3 votes but show only 1. I not use shortcodes, I use direct widget and add post ID. the post ID is correct and I not use other caching plugins.

    Plugin Author Gemini Labs

    (@geminilabs)

    @vipearn

    I just submitted a review on the /checkclix-reviews/ page on your website and the submitted review displays correctly.

    1. Does this problem happen for you consistently on every page, or only on a particular page?

    2. Have you tried clicking the “Recalculate Counts” button on the “Site Reviews > Tools” page?

    3. If you are able to make an account on your website with an “editor” role and send me the login credentials, I would be able to help you much more quickly.

    If not, please send me the URL of the page you are having problems with, and ALSO, please go to the “Site Reviews > Tools” page and download both the “System Info” and the “Console”, then email these files to: site-reviews[at]geminilabs.io

    This problem is in the last review post I am not checked all posts but I think that only there have a problem. I will change your account status to administrator.

    Plugin Author Gemini Labs

    (@geminilabs)

    Okay. In this case I suggest you also install the UpdraftPlus plugin and make a complete backup of your site and database. Always good to be cautious.

    Once you’ve done that, please let me know the URL (or slug) of the page you are having problems with and let me know when I can login.

    Thanks

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Error from last updates’ is closed to new replies.