WordPress.org

Support

Support » Plugins and Hacks » Error from last API Key attempt

Error from last API Key attempt

  • I’m having a bit of an issue.

    Background: I have several self hosted blogs, I have WordPress Stats on all of them, some are mine and are branched off my wordpress.com account, and others are sites that I’ve done for others that I’ve set up their own wordpress.com account for their own unique api key, username and password.

    Issue: One of these sites, redfishriviera.com/blog, I set up their own wordpress.com account so as to give them their own username and password associated with their api key so that they could have their own login to their stats (as opposed to using my personal un/pw). When I plug that api key into the WordPress Stats plugin, I get this error:

    Error from last API Key attempt:

    Missing API Key

    Then it says:

    The WordPress.com Stats Plugin is not working because it needs to be linked to a WordPress.com account.

    Enter your WordPress.com API key to link this blog to your WordPress.com account. Be sure to use your own API key! Using any other key will lock you out of your stats. (Get your key here.)

    I’ve set up two different wordpress.com accounts in addition to the first hoping to get a different result, with no luck. I can’t figure out why I’m having this issue.

    I was thinking maybe somehow (through cookies, etc.) it was smart enough to know that I have other wordpress.com accounts and didn’t want me to do this, but I’ve cleared all cache, etc. and redone everything. I’ve considered backing up the db and reinstalling wordpress, but I worry that there may be something in the tables corrupting my chances.

    I just don’t know where to look or how to diagnose the exact problem.

    Does anyone have any insight into this? I’m totally stumped.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I got the act same problem…!! help please

    myusuf3

    @myusuf3

    same here.

    gregdevore

    @gregdevore

    I am having this same problem. It just creates an endless loop.

    Me too. I saw a post which suggested the need for allowing 3rd party cookies, another which reported it was fixed by clearing your cookies and trying again. Neither worked for me. Nor did logging out of both wordpress.com and my own site. The error message is presumably not reflecting the actual error – since it gets into the loop even when there is a key and it is correct.

    I’m using it with 2.6.0 – I wonder if anyone is having the same problem with 2.6.1? i.e. would upgrading fix this?

    Was getting the same error, but the error didn’t accurately reflect what the problem was. The problem was the another WordPress.com account already “owned” that blog.

    This is what fixed my problem:
    How do I Change the API Key Used for WordPress.com Stats?

    I have the same problem with 2.7

    I hardcoded the key in stats.php as follows:

    // You can hardcode a WP.com API key here.
    $stats_wpcom_api_key = ‘xxxxxxxxxxxx’;

    Didn’t help.

    Having the same issue with 2.7 here..
    I have 2 accounts at wordpress.com
    None of the API-keys is functional..
    I only get : “Error from last API Key attempt: Missing API Key”

    Is this a bug? Or am I missing something?

    I’m having the same problem. 2.7.1 I’m a bit stuck. 🙁

    @shanepike: thanks its working

    I have several wordpress.com blogs and because of the advertising restrictions I encountered, I created the same blogs through wordpress.org. I am trying to install the stats plugin in all of them but it won’t let me because the new wordpress.org blogs have to be linked to the API number and that number is the same for all the blogs I have through wordpress.com.

    This is the error I get:

    “Error from last API Key attempt: The owner of that API Key is not on the access list for this blog. To be added to the access list, you must contact support.”

    Who is support? I thought the Forum was the only help we could get. Does anybody know what I should do?

    @shanepike: yes, it’s working for me, too. thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error from last API Key attempt’ is closed to new replies.