Support » Plugin: Loco Translate » Error: Forbidden

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Tim W

    (@timwhitlock)

    I don’t think mod_sec would show in phpinfo. I’m not 100% sure, but it’s an Apache module (nothing to do with PHP) so check with your hosting provider if it’s installed.

    Hi Tim 😉
    Thanks for getting back on this.

    I have a clone dev site just besides this one, and did some testings.
    Now I realize that the problem has to be with the plugin(s) that I want to translate.

    I can’t do any edit (Error: Forbidden) on some plugins like:

    • bbPress Advanced Statistics
    • Give – Donation Plugin

    It works on:

    • WP Maintenance
    • WP User Avatar

    So… it seems to be a plugin problem.
    Not on your side.

    Kind Regards,

    Yves

    Plugin Author Tim W

    (@timwhitlock)

    Thanks for posting back. I’m keen to reproduce the issue for myself anyway, so I’ll check out bbPress Advanced Statistics. I assume it’s this: https://wordpress.org/plugins/bbpress-improved-statistics-users-online/ ?

    Exactly Tim 😉
    I will download the new version and see if I still get the same isue…

    Will let you know…

    Cheers,

    Yves

    Just realized I am already with the latest version 1.3.11 🙁
    😉

    Just tested and same issue with version 1.2.2
    I opened a ticket for Jake (the author)

    Error: Forbidden when trying to translate with Loco Translate

    Plugin Author Tim W

    (@timwhitlock)

    I have no issue saving translation files for the bbPress Advanced Statistics plugin.

    I also have no issues saving translations for my plugin, I don’t have much experience with this plugin however.

    Anticosti, is this happening for any string you try to translate? Would you mind providing some more info here.

    If it turns out to be something wonky with what I am doing, I am more than happy to correct it.

    Regards,

    Oh boy… curious stuff…
    Tim and Jake have no problems.
    Then… the problem is ON ME 😉
    Really sorry about bothering you guys with this 🙁
    I love both your plugins… let’s have a nice weekend and maybe I’ll find something next week?

    Appreciate your efforts,

    Kind Regards,

    Yves

    Plugin Author Tim W

    (@timwhitlock)

    If anyone gets to the bottom of this I’d love to know what’s going on. Many people have reported it and I’ve never been able to reproduce it.

    I would say it’s unlikely to be the fault of the plugin being translated. Saving a translation file doesn’t mean that Loco is interacting with the plugin being translated at all. (i.e. It doesn’t execute any of its code). It’s more likely something extraneous to both plugins.

    I experienced the same issue. After investigation, I found out that this Forbidden Error caused by the WordFence plugin. The Firewall functionality block that action.
    If you also have WordFence Running, try to disable it to check. You can whitelist the action by click on PO Download, Wordfence will show a warning where you can click the option to whitelist it. Then you can save the translate now.

    Plugin Author Tim W

    (@timwhitlock)

    Thanks for this information, Thuan. I will look at the WordFence plugin and ensure that Loco version 2.0 is compatible with whatever security measures it implements.

    Great info! That wll maybe help me find something on my side, when I’ll get back to town.
    The plugin that I first want to desactivate, will be cleantalk-spam-protect. Not sure… But… Who knows?

    Regards,

    Yves

    Back in Town 😉
    I have some non-exhaustive tests results for now.
    I pulled out all the plugins except of course, Loco Translate.

    One by one, I brought back in some of my plugins (small test for now).
    I simply checked if I could save the fr_FR translation for each plugin.

    Here the results:

    Translation saving OK:
    bbp-last-post
    bbpress-private-replies
    better-search
    download-manager
    email-to-download
    geo-my-wp

    Translation not saving (Error: Forbidden)
    404page
    admin-custom-login
    advanced-ads
    bbp-private-groups
    bbp-style-pack
    bbpress
    bbpress-improved-staoes not make sensetistics-users-online
    bbpress-notify-nospam
    wp-user-frontend-pro

    I could have went through all my 70 plugins in there but…
    does not make sense.

    Theses results seems to prove that my setup is OK and… that the problem needs to be solved on a per plugin basis. Well… I may be wrong? Don’t know?

    Isn’t this puzzling?

    Have a great weekend!!!
    Kind Regards,

    Yves

    Just realized that the plugins that works and behaves OK are the ones that have no “.pot” file in their “plugin-name/languages” directory and they have at least an english en_US.mo and en_US.po version in there.

    Example:
    wp-content/plugins/better-search
    wp-content/plugins/better-search/languages/better-search-en_US.mo
    wp-content/plugins/better-search/languages/better-search-en_US.po

    No .pot file in plugins/better-search/languages/
    and it saves perfectly in my: wp-content/languages/plugins/

    When in Loco Translate, I click on “Sync” here’s the result message:
    OK: Already up to date with better-search-en_US.pot which proves my assumptions 😉

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Error: Forbidden’ is closed to new replies.