Support » Plugin: Yoast SEO » Error for noindex checkout, cart and my account

  • Resolved ghostgear101

    (@ghostgear101)


    i have a search console error for submitted url marked noindex for the cart, checkout and my account pages. what should be done to fix this without causing any other error?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    @ghostgear101,

    In most sites, “My Account”, “Cart and “Checkout” pages contain very little content, which is why Google reports a soft 404 error. In order to stop seeing these errors, you will need to noindex the URLs by following these steps.

    I hope this clarifies your concern.

    Thread Starter ghostgear101

    (@ghostgear101)

    ok i will check it out

    Thread Starter ghostgear101

    (@ghostgear101)

    The link doesnt open a page

    Plugin Support Michael Tina

    (@mikes41720)

    @ghostgear101 we apologize for not providing the correct link. You can follow the steps in this article — https://yoast.com/help/how-do-i-noindex-urls/

    Thread Starter ghostgear101

    (@ghostgear101)

    Thank you. I was looking at this again and i don’t see these pages in the xml sitemap. so if it should’t be indexed why are they giving me a error?

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @ghostgear101,

    That’s odd. If they are indeed not in the sitemap, we are unsure why Google Search Console is telling you they were submitted. However, please know that WooCommerce by itself does output the noindex,follow meta tag to those pages and that is recommended.

    Thread Starter ghostgear101

    (@ghostgear101)

    Do you know what I should do So search console doesn’t flag me with this error? Should I resubmit the sitemap?

    Plugin Support devnihil

    (@devnihil)

    @ghostgear101 Yes, if you are still receiving a warning about the pages and have confirmed that they are not included in your sitemap, we would recommend removing the sitemap from Google Search Console and then resubmitting it.

    We suggest the following actions:

      1. Clear all your caching from your theme, plugin, server, CDN like CloudFlare or browser. If you are not sure how to clear caching from theme/plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider.
      2. Delete your sitemap in Google. Doing so will not hurt the SEO of the site. This guide explains more (scroll to the bottom): https://support.google.com/webmasters/answer/183669?hl=en.
      3. Submit the sitemap again. Be sure to submit only sitemap_index.xml and nothing else. This guide explains more: https://kb.yoast.com/kb/submit-sitemap-search-engines/.
    Thread Starter ghostgear101

    (@ghostgear101)

    Thank you. i went on to delete the sitemap and the error was gone. i guess it just took a few days to correct itself. thanks again

    Plugin Support Michael Tina

    (@mikes41720)

    @ghostgear101 we’re glad to hear that resubmitting the sitemap resolved the error. setting this to resolved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error for noindex checkout, cart and my account’ is closed to new replies.