Support » Fixing WordPress » “Error: file not found”, no post links (posts ok @ index page & dashboard side)

  • Installation seems ok;
    Wordpress Index webpage seems ok (latest posts show, and category links for other posts);
    1) None of the links to other categories (nor to “About” page) work – result is “!Error!” page;
    2) “View Post” feature results in same on Dashboard side;
    3) Checking the WordPress folder/directory on my website, there do not seem to be any extra files/folders/directories created as a result of posting, creating page:
    4) I had been creating (and backdating) posts with gusto, several categories under year/month/ format, and a couple of my own; all of this seemed to have gone well Dashboard side – simply not following through webside.

    I feel like there is an elementary mistake. Any ideas? Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Here are a coiple of links as examples”
    Shows the latest few posts fine, and all the category, page links;
    Single page I have;
    Latest post;
    Typical category;

    Everything seems fine posting on the dashboard side; I can access all the different posts and categories.

    Here is the spiel from the WordPress directory on the website:

    File Manager

    Click on a folder icon to navigate.
    Click on a name to view its properties.
    / public_html / wordpress / (Current Folder)
    Create New Folder
    Upload file(s)
    Up one level
    wp-admin 755
    wp-content 755
    wp-includes 755
    Create New File
    index.php 0 k 0644
    license.txt 14 k 0644
    readme.html 7 k 0644
    wp-app.php 32 k 0644
    wp-atom.php 0 k 0644
    wp-blog-header.php 1 k 0644
    wp-comments-post.php 2 k 0644
    wp-commentsrss2.php 0 k 0644
    wp-config-sample.php 1 k 0644
    wp-config.php 1 k 0644
    wp-cron.php 0 k 0644
    wp-feed.php 0 k 0644
    wp-links-opml.php 1 k 0644
    wp-login.php 15 k 0644
    wp-mail.php 5 k 0644
    wp-pass.php 0 k 0644
    wp-rdf.php 0 k 0644
    wp-register.php 0 k 0644
    wp-rss.php 0 k 0644
    wp-rss2.php 0 k 0644
    wp-settings.php 13 k 0644
    wp-trackback.php 3 k 0644
    xmlrpc.php 66 k 0644

    And just a few examples of the posts dashboard side (the last two I can’t access via the website links):

    2008/03/07 [07/03/2008] What Your Vote on the Lisbon Treaty Will Really Mean admin Lisbon Treaty No Tags
    2008/02/15 [15/02/2008] WHAT THE TREATY OF LISBON DOES admin Lisbon Treaty No Tags
    2007/10/18 [18/10/2007] Government should set up the statutory Referendum Commission well in advance of the referendum on the new EU Treaty to ensure citizens are adequately informed admin Uncategorized No Tags

    Another thing:
    I can preview the posts just fine _before_ I save or publish them (which is why I got lazy and didn’t bother checking the webside URLs until after I had finished uploading all the posts); after saving/publishing I get an error message when using their permalinks (and the permalinks seem to repeat the post title in the URL, but it makes no difference if I cut one of the repeats, or leave it as is).

    Ok, I hadn’t come up with anything through the search words option, but then tried under the “Installation” Forum (hadn’t thought of this before, because I’d thought the installation went alright). The Thread is called, and located at:

    “Upgraded to 2.5, now pages don’t display… WTF?”

    I didn’t understand a lot of it, but for those of you who are having this problem, and who like me who have no formal training in, or deep knowledge of computers, here we go…:


    1) Log in;
    2) On the “Dashboard”, wander over to your top right, where it says “Settings, Plugins, Users”, and Click on “SETTINGS”;
    3) Now wander over the next page to Click on “PERMALINKS” (this will be one of several options probably listed over the title “General Settings”);
    4) You should now see the title “Customize Permalink Structure”;
    Under this, there will be little buttons beside a list of options;
    There are now two options to fix the post/page error:
    a) – Click the “DEFAULT” button;
    – Click on the “SAVE CHANGES” link near the bottom of the page;
    (this will mean that the URL’s/Web addresses of your posts will end in something like “?p=123”); OR
    b) – Click on the button of your preferred option (you should see some code pop into the box beside “Custom”;
    – THEN Click the button beside “CUSTOM”;
    – Now, in the box beside “Custom” and right BEFORE the string of code that’s in there, insert what’s BETWEEN these quotation marks: “index.php?”;
    – Click on the “SAVE CHANGES” link near the bottom of the page;
    (This will give you an URL/Web address for each of your posts almost the same as your preferred option, but just with “/index.php?/” preceding it).

    This seems to work; although there is apparently some fix that you can do that removes the “index.php?”, I must confess I don’t really understand how it’s done; I will leave this thread open a bit longer in case any of you more advanced people wish to explain it (hint: imagine that you are playing with “mechano” sets, whereas I am still playing with “duplo” bricks (“Lego” bricks being too small and fiddly…)).

    Thanks in advance, and hope this is of some help to someone else.

    Update re: categories —
    Unfortunately, the second fix b) seems not to work with categories; you have to select option a), that is the default permalinks, sorry.

    BTW this seems to be a common problem; any of you who understand how this is solved in relatively simple terms, please let us know.



    dear ooconnell, first of all thank you very much, ’cause I’m have the same annoying problem, and I don’t know why I can’t find the good solution to it. I did as you explained, and everything worked fine to me! that’s cool man.. By the way, do you know if that fix would change anything in the google indexing?

    Thanks again to the help you provided!
    Marco photography

    Yes, that worked for me as well. I have index.php in front of all my posts, but at least they link now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘“Error: file not found”, no post links (posts ok @ index page & dashboard side)’ is closed to new replies.