Support » Plugin: Quttera Web Malware Scanner » ERROR Failed to update option qtr_scan_cron_args

  • Resolved advertino

    (@advertino)


    Hi, guys.

    I don’t quite understand what’s going on. The point is that all of my blogs are installed with almost the same settings. However, on one of the blogs, the scan does not start. I disabled all plugins but nothing changes.

    In the error logs there are clear records that the connection was refused.

    [11-Nov-2021 04:12:26 UTC] Connection refused

    After I added a line of code to the config file

    define(‘QTR_FS_SNAPSHOT’, true);

    the entries in the error log changed.

    [11-Nov-2021 04:16:06 UTC] PHP Warning: Use of undefined constant ‘QTR_FS_SNAPSHOT’ – assumed ‘‘QTR_FS_SNAPSHOT’’ (this will throw an Error in a future version of PHP) in /home/******/public_html/******/wp-config.php on line 76
    [11-Nov-2021 04:16:06 UTC] Connection refused

    Any idea?

    • This topic was modified 9 months ago by advertino.
    • This topic was modified 9 months ago by advertino.
Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Author quttera

    (@quttera)

    The qtrOptions.php should be located in our plugin directory.

    But this error means that WordPress’s core function “update_option” failed to store value for option “qtr_scan_cron_args”

    But since the “QTR_FS_SNAPSHOT” constant is defined, the plugin actually should store “qtr_scan_cron_args” data on the file system.

    Please try to investigate why WP-Cron system returns error 503?
    The cron job invocation is done by the website domain name + URL + doing_wp_cron query parameter. It means that WP invokes this URL which goes back to Cloudflare (since domain name resolved to Cloudflare) and just then goes back to WP.

    Can you please check/compare the Cloudflare configuration of this and other blogs?
    Without proper WP-cron functionality, the internal scanner won’t work.

    Thread Starter advertino

    (@advertino)

    HTTP/HTTPS fixed, nothing change

    Thread Starter advertino

    (@advertino)

    I think I found an error. I turned off Cloudflare and it worked. Now I have a question, what is the difference between the CF settings of one website and the settings of another. I think I’ll figure it out on my own.

    Thanks for support!

    • This reply was modified 9 months ago by advertino.
    Plugin Author quttera

    (@quttera)

    Thank you for the update.

    In general based on our experience Cloudflare servers (proxies handling http requests) behaving differently from server to server even the protected websites having identical configuration. This is what we see with our commercial products.

    Please let us know if you found what exactly was blocked by Cloudflare.

    Best Regards
    Michael
    Quttera Team

    Thread Starter advertino

    (@advertino)

    Sure, I’ll check it.

    • This reply was modified 9 months ago by advertino.
    • This reply was modified 9 months ago by advertino.
    Thread Starter advertino

    (@advertino)

    It looks a little strange, but in the Cloudflare panel I found a huge number of bots from Germany being blocked. When I disabled the CF firewall, everything started working without any problems. The only thing I can’t figure out is how the bots from Germany relate to the cron, which runs on a website that is hosted in Singapore. But now everything works. It is a fact.

    Capture5

    Plugin Author quttera

    (@quttera)

    Thank you,

    Try to whitelist your host server IP,

    This can help to keep plug-in working with enabled Cloudflare.

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘ERROR Failed to update option qtr_scan_cron_args’ is closed to new replies.