Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Error Exporting Donors

  • Resolved jesseslam

    (@jesseslam)


    Hi,

    When trying to export donors I get the below error do you know how we can fix this?

    There is nothing in the logs about this.

    We are using W3 Total Cache and Autoptimize and disabling these also doesn’t fix it.

    This site can’t be reached

    The webpage at webaddress/wp-admin/?donor_export_start_date&donor_export_end_date&forms=0&give_export_option%5Bfull_name%5D=on&give_export_option%5Bemail%5D=on&give_export_option%5Baddress%5D=on&give_export_option%5Buserid%5D=on&give_export_option%5Bdonor_created_date%5D=on&give_export_option%5Bdonations%5D=on&give_export_option%5Bdonation_sum%5D=on&give_export_option%5Bquery_id%5D=give_5d9c795e11253&give_ajax_export=3f7b382a94&_wp_http_referer=/wp-admin/edit.php?post_type=give_forms&page=give-tools&tab=export&give-export-class=Give_Batch_Donors_Export&step=1&class=Give_Batch_Donors_Export&nonce=f64c4f6595&give_action=form_batch_export might be temporarily down or it may have moved permanently to a new web address.
    ERR_INVALID_RESPONSE

    Regards,

    Jim Isles

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi @jesseslam

    I’ve not seen an export cause this error before. My first step to getting to the bottom of this would be to try and isolate the problem.

    1. Do all exports cause errors, or just Donor exports?
    2. If you try different options (add a start and end date, or select a different set of columns, etc) will it export correctly?
    3. I’d also like to see what version of PHP and other things you are running.

    Navigate to Donations –> Tools –> System Info (tab) and click the button to “Get System Report” and copy/paste that in your reply here. If needed you can redact any information that identifies the site in that text.

    ​That will give me some more context to be able to help.

    Thanks!

    Hi,

    Thanks for coming back to me on this but for the time being I have used another solution as we need to get this done ASAP. My client may use this in the future and if the issue still remains I will post again.

    Regards,

    James

    I ran into this same error. It occurs for all the reports, Both the pdf and csv reports were breaking. I gave up and started using the API. I submitted a support ticket on this as well. I’m free to fix it.

    Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi folks,

    We are aware of an issue with W3 Total Cache that was causing this issue, but it appears they are fixing the problem on their end.

    @only1kairi if you are able to replicate the problem on a site without W3TC enabled, let me know some steps to replicate it, and I am happy to follow up to see if the issue is more widespread.

    As of now, the only way we’ve been able to reproduce this issue is with W3TC enabled on the site. So the workaround is to temporarily disable W3TC and run the reports.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.