• Resolved Marty

    (@bozzmedia)


    Hello–

    Plugin is working great, just wanted to report I’ve recently been receiving this error after performing some plugin updates in the admin.

    When I check redis connections in the plugin they look fine, manual cache flush is also working. Not sure if I should be concerned about this, perhaps an issue with the auto cache flush after plugin update?

    Error establishing a Redis connection

    read error on connection to 127.0.0.1:6379

    This means that the connection information in your wp-config.php file are incorrect or that the Redis server is unreachable.

    Are you sure you have the correct Redis host and port?
    Are you sure Redis server is running?

    If you need help, please read the installation instructions.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter Marty

    (@bozzmedia)

    Diagnostic info:

    Status: Connected
    Client: PhpRedis (v5.3.7)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.7
    Relay: Not loaded
    Predis: 2.1.2
    Credis: Not loaded
    PHP Version: 8.0.28
    Plugin Version: 2.4.1
    Redis Version: 3.2.12
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 195
    Filesystem: Working
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_DATABASE: 1
    WP_REDIS_MAXTTL: "46400"
    WP_REDIS_PLUGIN_PATH: "/home/redacted/public_html/production/wp-content/plugins/redis-cache"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "themes",
        "theme_json",
        "itsec-lockouts"
    ]
    Unflushable Groups: []
    Groups Types: {
        "blog-details": "global",
        "blog-id-cache": "global",
        "blog-lookup": "global",
        "global-posts": "global",
        "networks": "global",
        "rss": "global",
        "sites": "global",
        "site-details": "global",
        "site-lookup": "global",
        "site-options": "global",
        "site-transient": "global",
        "users": "global",
        "useremail": "global",
        "userlogins": "global",
        "usermeta": "global",
        "user_meta": "global",
        "userslugs": "global",
        "redis-cache": "global",
        "counts": "ignored",
        "plugins": "ignored",
        "themes": "ignored",
        "blog_meta": "global",
        "theme_json": "ignored",
        "itsec-lockouts": "ignored"
    }
    Drop-ins: [
        "maintenance.php v by ",
        "Redis Object Cache Drop-In v2.4.1 by Till Krüss"
    ]
    Plugin Author Till Krüss

    (@tillkruess)

    Try restarting Redis server, or using a monitoring tool for it.

    Good evening, I’m writing from Italy, sorry for my bad english.

    I have my site down due to redis plugin. The error is

    Error establishing a Redis connection

    Connection timed out

    This means that the connection information in your wp-config.php file are incorrect or that the Redis server is unreachable.

    • Are you sure you have the correct Redis host and port?
    • Are you sure Redis server is running?

    If you need help, please read the installation instructions.

    So, I red other comments but I’m not an expert and I don’t know how to find wp-config.php or how to use wp-content/object-cache.php drop-in file

    Please help me

    Thanks a lot in advance

    Plugin Author Till Krüss

    (@tillkruess)

    Hey! If you cannot find your wp-config.php file please ask your hosting provider for assistance with configuring Redis Object Cache.

    I did it, but without any reply.

    My hosting provider is OVHCloud.

    I’m not an expert of web site, but just an applicant. could you lead me in searching the php files? is in the hosting page or on my pc?

    Plugin Author Till Krüss

    (@tillkruess)

    I’d suggest reading the WordPress documentation or Googling your requests.

Viewing 6 replies - 1 through 6 (of 6 total)

The topic ‘Error establishing a Redis connection – only on plugin updates’ is closed to new replies.