Support » Plugin: Redis Object Cache » Error establishing a Redis connection

  • Resolved ventio

    (@ventio)


    I have a problem that happens quite frequently. Sometimes it happens that when you try to open the website, you get the error “to disable redis delete the object-cache.php file in the /wp-content/ directory.”
    After refreshing, the page loads correctly.
    What could cause such a problem? Where to look for the cause of the problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    That sounds like your Redis Server is not reachable “quite frequently”. Consider monitoring it and assigning it more resources.

    Thomas Jarvis

    (@thomasjarvisdesign)

    I also had this same error. It appears to be a memory allocation problem for me. The Redis Cache was not big enough and plesk could not allocate the full amount I had asked it to.

    Try checking how much free ram you have and restart redis cache to see if it comes back up again.

    As a temp solution. Disable redis and just use whatever page caching you have in place.

    Plugin Author Till Krüss

    (@tillkruess)

    @thomasjarvisdesign: How did you discover this? Would it be helpful to see the current Redis memory size in the dashboard?

    Thomas Jarvis

    (@thomasjarvisdesign)

    @tillkruess

    Sorry it has taken a while to get back to you.

    This randomly happened on a site and I had to delete the file suggested in the original post to bring the site back online.

    Redis is installed in a 3gb docker container on the server. When attempting to re-initialise Redis from Docker it couldnt allocate the full 3gb (error code explaning issue cannot remember exact code). The cause (unverified) is below:

    Now that memory use is down again:
    I think this is to do with me running Redis in Docker and Memory overcommit must be enabled. Memory Overcommit is disabled and I recently started using Optimus Cache Primer which causes the server resources to hit 100% for a hour or so every night and also spank Redis cache as it will cache all of the queries made by the cache primer.

    I am going to remove Redis and Docker and then install Redis directly onto the server. Then re-configure with Overcommit enabled. I think this will be more stable. I had taken a novice approach to this and used the Bitnami version of Redis on Docker because it includes a load of common variables that would otherwise need to be added to the Redis conf file. But now I understand how it works I wont really have an issue adding/editing the conf file without using Docker.

    I hope this helps. I’ll let you know if it falls over again and raise my own ticket with full details.

    I have exact same issue and now installed redis directly onto the server today and removed docker image. Has this fixed the issue for you? @thomasjarvisdesign:

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.