Support » Installing WordPress » Error establishing a database connection on fresh install of 3.4.2

  • Resolved dale.vanzile


    I just installed 3.4.2 on my server, and followed the instructions here ( to the letter, substituting real servername, databasename, username, and password where appropriate, and I receive the dreaded “Error establishing a database connection” when I try to visit the site or log in to the site.

    I created a testconnection.php page in the folder where WP is installed that tests the database connection, and it verifies that my user/pass combo for the user is correct and that it successfully executed the mysql_select_db command with the database involved. It even pulls the wp_users table and spits out a row count (currently 1 user: admin).

    I tailed my error log, and found this pair of error messages (server and folder names changed to protect the innocent 😀 ):

    [Thu Nov 15 15:37:22 2012] [error] [client nnn.nnn.nn.nn] PHP Warning: include_once(/var/www/installfoldername/wp-content/sunrise.php): failed to open stream: No such file or directory in /var/www/installfoldername/wp-includes/ms-settings.php on line 18, referer:

    [Thu Nov 15 15:37:22 2012] [error] [client nnn.nnn.nn.nn] PHP Warning: include_once(): Failed opening ‘/var/www/installfoldername/wp-content/sunrise.php’ for inclusion (include_path=’.:/usr/share/pear:/usr/share/php’) in /var/www/installfoldername/wp-includes/ms-settings.php on line 18, referer:

    It seems to want the sunrise.php file, but the install tarball does not provide it.

    Kinda got a headache from beating my head against the desk.




Viewing 3 replies - 1 through 3 (of 3 total)
  • – First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    – double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don’t need to change the database host from “localhost” to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.

    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

    Thanks for the help. I *am* my own service provider. The DB is fine, I can connect to it, use the appropriate database, and even pull records from it.

    The issue seems to be a missing sunrise.php file. Where can I obtain this file?


    re-doing the installation from scratch with a fresh download of the installation tarball.

    hopefully i won’t encounter the same error again.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error establishing a database connection on fresh install of 3.4.2’ is closed to new replies.