WordPress.org

Support

Support » How-To and Troubleshooting » Error establishing a database connection after plugin change?

Error establishing a database connection after plugin change?

  • The Image-Headlines plugin has been giving me some trouble recently, so I went into the headlines admin page to change a setting, and next thing I know, I get a Error establishing a database connection error! I backed up my database, deleted my database, and uploaded the backup, but no such luck! I don’t know what could be the cause!

    Just before it went down, I changed the preview text for the plugin from the quick lazy dog to Sato’s text “something in quotes” thingy. I believe it may be the quotes that ae causing the problem, but I can’t find the offending string ANYWHERE in my database!

    Any ideas?

    Edit: I double checked my wp-config.php, and it’s all good… so… I dunno…

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hopefully you backed up to something recent. Have tried the author’s site to see if he has any suggestions?

    The backup was just after the database went down, which may explain why it still is down (there’s something wrong with it, maybe)… Maybe if I grab an older backup and upload that, it might work…

    I was originally posting on the author’s site about the problems that the plugin was giving me before this issue, but that means nothing now =P I’ll try his site a little later.

    Check with your host to see if they have a backup fairly recent….

    I can’t quite see why a plugin change like that would crap the whole database though.

    I don’t trust Technolojik to have a backup, they haven’t answered my last three e-mails about various issues, so I doubt they actually do anything…

    I do have some older backups, and I should be able to just bring over some of the tables from the current backup, such as posts and comments…

    I hope so, Satoshi! I have such a great host I forget others don’t have that luxury….

    Good luck with it, let us know!

    Ah! It’s not just WordPress! Coppermine gives the following error:

    Coppermine critical error:
    Unable to connect to database !

    MySQL said: Client does not support authentication protocol requested by server; consider upgrading MySQL client

    Whoa! I’m scared… What’s really weird is that this was ALL working just the second before. There was no downtime (at least not anytime close to this incident, there was some major downtime earlier, though) that could have caused it… Bah, darn Technolojik!

    Edit: Even weirder: The other WordPress installs (version 1.2) still work fine…

    Edit2: Old database does not work properly… Still gives the same error…

    Check with your host – I know they may not answer…. but I’ll bet they did something weird with php or mysql. A version “upgrade” or “retrograde” can sometimes cause this sort of stuff.

    Will do… I’ve been meaning to get on their back for some of the recent problems for quite some time, but that will come in a length e-mail after this problem is all sorted out…

    And then maybe check out the “Hosting” tab above? Looks like some great hosts there….

    Heh, I was thinking of moving to A Small Orange as of late. I’ve already found a plan that would suit me perfectly. However, I am part of a community-based site, and it would probably cost a lot more to get a plan of equal value (or at least one that can support us) at ASO. Plus, if I leave, I would be fracturing the community… Decisions decisions…

    Ugh. Been there done that. My decision was ultimately to “bludgeon” the community into the change, because I was and am the one doing the work. YMMV…..

    Alright, e-mail sent… Hopefully they can understand it… Darn Turkish based host (nothing against Turks, just that it doesn’t make much sense to have a company that primarily serves American citizens and English speaking people based in Turkey…)..

    Er. Well, everyone’s doing offshore these days…. fact of life I guess. Let us know how it goes!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error establishing a database connection after plugin change?’ is closed to new replies.
Skip to toolbar