Support » Fixing WordPress » Error establishing a database connection

  • Hello,

    I AM HAVING A PROBLEM WITH MY WORDPRESS WEBSITE. WHEN VISTED IT SAYS: Error establishing a database connection

    I CAN ONLY LOG IN TO CPANEL.

    WHAT CAN I DO?

    MY WP-COFING FILE CODES ARE;

    <?php
    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to “wp-config.php” and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘zlscor_wp830’);

    /** MySQL database username */
    define(‘DB_USER’, ‘xxxx’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘xxxxx’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define(‘AUTH_KEY’, ‘xx’);
    define(‘SECURE_AUTH_KEY’, ‘xx’);
    define(‘LOGGED_IN_KEY’, ‘xx’);
    define(‘NONCE_KEY’, ‘xx’);
    define(‘AUTH_SALT’, ‘xx’);
    define(‘SECURE_AUTH_SALT’, ‘xx’);
    define(‘LOGGED_IN_SALT’, ‘xx’);
    define(‘NONCE_SALT’, ‘xx’);

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wpt6_’;

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    • This topic was modified 2 months, 1 week ago by  Steve Stern. Reason: removed passwords

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    1. Is the database server up? Ask your host.

    2. Verify that you have the correct values for the DB_ constants.

    Note: I removed passwords from your wp-config file. There was no need to post it. PLEASE CHANGE YOUR DATABASE PASSWORD IMMEDIATELY. Contact your host if you do not know how to do that.

    Thank you very much Steve Stern (@sterndata)
    looking into that.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.